Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

My ATI card still giving low fps...

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
My ATI card still giving low fps...
First BioWare Post First BioWare Post

Sanquind's Avatar

12.15.2011 , 11:13 PM | #1
My specs:
CPU: Intel i5 core, 3.20 GHz.
Video card: Club3D Radeon 6850 HD, overclocked GPU from 775 to, 830 and memory clock from 1000 to 1150.

Yet when I play in game, my fps doesn't ever go above 40. And that's when everything's totally empty. With a few other players or npc's I'm glad to be getting 20 fps. If it's a little bit busy, at most 13~14 fps. I've tried lowering all settings, but it hardly helps my fps if at all. I've set my card for full high performance but still no real change.

This was almost the same in beta. It was a bit lower back then even, but still. What I'm most worried about is in beta it was stuttering so much that it was pretty much unplayable.

Ratae's Avatar

12.15.2011 , 11:16 PM | #2 Click here to go to the next staff post in this thread. Next  

Hello Sanquind,

This thread contains some good suggestions for possible solutions to Radeon FPS issues:

Perhaps you would like to give this a try. Thank you.

Ratae | BioWare Customer Service - Forum Support

Sanquind's Avatar

12.15.2011 , 11:33 PM | #3
Tried those things, set everything in game to the bare minimum, in an indoor area with no one else around. And in total it gave me no fps increase at all, and only a little bit more stability in fps. Like, it wouldn't drop to 20 any more in the enclosed space, but instead to 23.

Btw I have the newest driver 11.12, and don't use crossfire.

Rohrnin's Avatar

12.15.2011 , 11:42 PM | #4
Just as a suggestion... my wife has a Radeon (sorry I can't remember 6750??? I dunno 1GB RAM etc.)

Anyway SWToR ran great first 2 beta weekends. She updated her drivers from 10.9 to 11.whatever just to be all up to date and on the last weekend it was horrid! Also there were some weird video glitching on rare occasions with lines across the image.

Reverted back to 10.9 (for her card anyway) ... problem solved.

May not help at all, but thought I would throw it out there just in case.

KarlSmash's Avatar

12.15.2011 , 11:47 PM | #5
Make sure you are either fully updated with drivers, and if you just updated, revert back.

I have a 6970 and I average like 70-80 fps. I am running 11.10 I think, the last update they did before Skyrim came out.

Sanquind's Avatar

12.15.2011 , 11:48 PM | #6
I had 11.10 before the beta I tried. And it gave me worse fps than the 11.11 one. 11.12 is about the same as 11.11.

KarlSmash's Avatar

12.15.2011 , 11:51 PM | #7
Remove your overclock temporarily and see if that helps. Some games don't run stable when on overclocked cards. Especially MMOs which are very memory intensive games.

I had a problem like this a looong time ago when playing WoW on my Nvidia GTX260.

Sanquind's Avatar

12.15.2011 , 11:53 PM | #8
I ran the game without overclock the first time in beta. It gave slightly worse results. But I'll try again to make sure.

Sanquind's Avatar

12.16.2011 , 12:29 AM | #9
None of that worked either.

buffnblue's Avatar

12.16.2011 , 11:14 AM | #10
I have an ATI 5450 card and Im getting 5-10 fps. Its horrible. I jsut got my computer in feb 2011, so I have the AMD equivalent of the i5 intel, and 6 megs of ram. I was playing DAoC, WoW, and AION prior to this with no problem. Any clues?