Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Problem with Force Armor on some tanks ?

STAR WARS: The Old Republic > English > Classes > Sage / Sorcerer
Problem with Force Armor on some tanks ?

Moooog's Avatar


Moooog
02.21.2012 , 03:37 AM | #1
Hello,

I posted this in another section but didnt get an answer so I thought I would try here
I've been playing a seer specced sage since I started the game and I'm facing an annoying problem when doing flashpoints...

Basically the problem is that after some time in a FP, for no apparent reason, I cant cast my Force Armor on my tank. It looks just like he still has the "debuff" that prevents him to get a new armor (sorry I dont have the english name in mind atm), even when it fades out.

In this case, the only way to reapply the armor is to let the tank die (which isnt really a solution) or me doing a complete restart of the game.

Note that in this situation, i can still cast the Armor on the other group members, it seems it only happens on the tank (only tried with a guardian & a shadow atm but both had the same issue).

Has anybody any infos on this issue ? maybe a cause or a way to solve it without having to quit the game ?

Thanks for reading and please excuse my poor english

Khadroth's Avatar


Khadroth
02.21.2012 , 07:24 AM | #2
Have you tried ctrl + U twice to see if that fixes the problem? Sounds like a UI problem to me.
The Starwind Legacy Anchorhead (PvP East)
"Tsu" 50 Miraluka Bala Sage "Soge" 3 Chiss Sniper
"Roronoa" 10 Pureblood Sentinel "Ashellia" 12 Borg PT
"Gene" 50 Human Gunslinger "Erza" 11 Human Jugg
"Shocktrooper" 16 Borg Comm "Hei" 1 Chiss Assassin

Orexxis's Avatar


Orexxis
02.21.2012 , 08:25 AM | #3
I've had this happen twice over the weekend too -- I couldn't armor anyone in my group besides myself during one FP, and it happened once during Soa on our tank.

Moooog's Avatar


Moooog
02.21.2012 , 09:16 AM | #4
@Khadroth : nah I tried to refresh the UI and the spell was still locked...

But somebody on another forum said that it happened to him after casting the Armor on someone and taking an elevator before it faded out, its worth a try, I'll post here if i find anything

Ichimi's Avatar


Ichimi
02.21.2012 , 10:45 PM | #5
This bug happens to my healing sage all the time. It always occurs when someone has the force armor cast on them then still has the cool down where we cannot recast while they zone/elevator/enter instance etc.

Only way I have ever been able to clear it is to log out and back to game. Not sure if letting them die works as I have not tried that. Lost out on a couple heroics cause it put me on different instances/steps having logged and that dropped me from group. Really frustrating when i log back in.

I have asked people in group who I cannot shield to bug report it. But most don't want to help bring the issue to light cause its not thier class/skill.


Edit for typo.

Moooog's Avatar


Moooog
02.22.2012 , 08:11 AM | #6
Quote: Originally Posted by Ichimi View Post
Lost out on a couple heroics cause it put me on different instances/steps having logged and that dropped me from group. Really frustrating when i log back in.
Didn't had time to do some tests with elevators yesterday but if you need to restart the game and you are in a FP/heroic, Alt-F4 is the best solution to prevent you from being kicked out of the group ; you'll appear as "disconnected" and will spawn right next to your group (sometime you'll need to do a /stuck after getting into the instance tho)

RobNightfall's Avatar


RobNightfall
02.22.2012 , 08:24 AM | #7
This sounds similar to a shadow tanking bug we're seeing right now. When guard gets blown off of someone in PvP we sometimes can't reapply it. I don't know if it's the same bug or something else with a similar effect.
Edited because the devs appear to have fixed at least 80% of the crap that was pissing me off.

Khadroth's Avatar


Khadroth
02.22.2012 , 09:42 AM | #8
Quote: Originally Posted by Ichimi View Post
This bug happens to my healing sage all the time. It always occurs when someone has the force armor cast on them then still has the cool down where we cannot recast while they zone/elevator/enter instance etc.

Only way I have ever been able to clear it is to log out and back to game. Not sure if letting them die works as I have not tried that. Lost out on a couple heroics cause it put me on different instances/steps having logged and that dropped me from group. Really frustrating when i log back in.

I have asked people in group who I cannot shield to bug report it. But most don't want to help bring the issue to light cause its not thier class/skill.


Edit for typo.
If that's the case you could try using the exit area command above your minimap before relogging to fix it. Should prevent any progression bugs like that.
The Starwind Legacy Anchorhead (PvP East)
"Tsu" 50 Miraluka Bala Sage "Soge" 3 Chiss Sniper
"Roronoa" 10 Pureblood Sentinel "Ashellia" 12 Borg PT
"Gene" 50 Human Gunslinger "Erza" 11 Human Jugg
"Shocktrooper" 16 Borg Comm "Hei" 1 Chiss Assassin