Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Catalyst Beta Driver 12.3 issue.

First BioWare Post First BioWare Post

PatchesOHoulihan's Avatar

02.20.2012 , 05:47 PM | #1
I know they are beta drivers, so it doesn't really matter if it works right or not. Just a heads up for other people who are thinking of getting these drivers. They help a lot of other games but damage this one.

JustinxDuff's Avatar

02.20.2012 , 05:48 PM | #2
Just curious, I saw these today.

What card are you running?
Bluntasaurus - Gunslinger - Ewoks Anonyous
Bluntskii - Sentinel - Ewoks Anonymous
Prophecy of the Five
Push the envelope, watch it bend

tullnd's Avatar

02.20.2012 , 06:03 PM | #3
No issues here. Sapphire 6970 twin fan version. Was running the pre-release 12.2 and almost updated to the production 12.2 just for kicks and thought I'd try 12.3.

Doesn't seem to have made any noticeable improvements(they don't claim any for this game that I see over 12.2), but seems to still work fine.

PatchesOHoulihan's Avatar

02.20.2012 , 06:08 PM | #4
I got Radeon 5770. Could it just get a catalyst setting causing it?

tullnd's Avatar

02.20.2012 , 06:10 PM | #5
Do a search on driver cleaner. Completely remove catalyst from your system, including registry. There are directions out there. Then reinstall fresh. Maybe just something corrupted and left over.

Cerimon's Avatar

02.20.2012 , 06:12 PM | #6 This is the last staff post in this thread.  
Greetings PatchesOHoulihan,

Thanks for the heads up Patches. Generally we advise against using Beta video drivers but we do appreciate the input.

Thank You for playing Star Wars™: The Old Republic™

Cerimon | BioWare Customer Service - Forum Support

PatchesOHoulihan's Avatar

02.20.2012 , 06:14 PM | #7
I used driver sweeper before I installed them.

Mikeni's Avatar

02.20.2012 , 07:20 PM | #8
The 12.3 beta drivers cause the same artifacting on my 5770's. I switched to the 12.2 Pre-Cert and all is fine.
• Chrondo [50] Jedi Sage • Coolie [27] Republic Commando - The Bastion - «RETIRED»
• Pretendo [32] Operative • Bomboclat [25] Mercenary - The Bastion - «ACTIVE»

• Ajunta Pall Refugee •

Korrigan's Avatar

03.03.2012 , 05:50 AM | #9
To fix this, disable antialiasing in game and force it through the Catalyst Control Center by creating an application profile for swtor.exe.
"The ability to speak does not make you intelligent." - Qui-Gon Jinn.

JJDunn's Avatar

03.03.2012 , 06:05 AM | #10
Quote: Originally Posted by Korrigan View Post
To fix this, disable antialiasing in game and force it through the Catalyst Control Center by creating an application profile for swtor.exe.
I can confirm this made little to no impact on performance but is better AA than what SWTOR offers.

Still can't enable high shadows though, stuck with low. I know they're not the prettiest thing but they make the worlds a bit more alive. Without them they're just.. dull.
The Progenitor - Jayfon