Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Login Service is currently unavailable?

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Login Service is currently unavailable?

besuvious's Avatar

12.15.2011 , 07:40 PM | #1
When I try to log in on my desktop my launcher says "login service is currently unavailable" and then refers me to the forums for help. My parents' computer does let me log in however. What could be the reason for this?

Racquerr's Avatar

12.15.2011 , 07:42 PM | #2
I think they either killed the login server or it's down for some other reason.

I get this too atm:

mookasabi's Avatar

12.15.2011 , 07:46 PM | #3
Just like to say that I am having the same problem as well, and have been for quite some time. First off it started with the beta. Had this problem, and something told me to do a system restore. So I did and it fixed it. I got to enjoy the beta. Then early access started. I re downloaded the launcher installed it, same issue again. Login server is currently unavailable. So I did a system restore again, it fixed it and I was able to patch my launcher. This was about 2 weeks ago. Today I click my launcher (keep in mind it was working last night) hoping I would have a play button for early access, only to be greeted by Login server is currently unavailable. I did yet another system restore because it fixed it the last 2 times, it worked but this time only temporary, I have the error yet again. I'm 100% sure its not my router, virus program, or firewall. Ive even went as far as completely disabling the virus and firewall programs with no luck. I have also pinged the bioware launch pad thing with success. That worked. I should also mention that someone else in my home has the early access installed on their computer, and IS NOT AND NEVER HAS had this problem. So it HAS to be something to do with the game not liking my computer, (maby it don't like WoW being on here lol) But there was one thing that I did notice. When I did the system restore today the error did go away and I was able to login. Then I noticed the system restore took off a few Windows updates. So I updated them and restarted my computer, I went to login and got the login server unavailable yet again. So could it be something to do with a Windows update? Sorry this post is so long, just wanted to be very specific about my problem and what I have done.


12.15.2011 , 07:50 PM | #4
I got this earlier after an error code 2005 disconnect. I had to reboot my router just to get internet service again. Worked again after that until I Dc'd with error code 9000. I was able to immediately retry logging but now I'm in a 30 minute queue.

Note: I had no problems on Tuesday or Wednesday.

Endmill's Avatar

12.15.2011 , 07:53 PM | #5
this thread has a lot of fix suggestons. None fixed it for me but hey you never know.

besuvious's Avatar

12.15.2011 , 07:54 PM | #6
I think it could be the amount of people LOGGING in right now, I heard that they brought in way more people for today, could just be a problem on their end.

mookasabi's Avatar

12.15.2011 , 11:29 PM | #7