Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Black scrren in game ?

First BioWare Post First BioWare Post

Glaedorn's Avatar

12.15.2011 , 05:06 PM | #1
Here when i start the game .. i can hear the intro and all but the screen is black .. my mouse of swtor is up and i hear something when i move it like im passing on the option but i cant see anything ... can anyone help me ?

Wildernes's Avatar

12.15.2011 , 05:08 PM | #2
i cant even seem to install the game!

Glaedorn's Avatar

12.15.2011 , 05:09 PM | #3
That dont help me at all lol but im sorry for you

iwakurakaitou's Avatar

12.15.2011 , 05:10 PM | #4
Quote: Originally Posted by Glaedorn View Post
That dont help me at all lol but im sorry for you
Have you tried unplugging your computer and plugging it back in?
Peace is a Lie, There is only Pudding.

Capmatt's Avatar

12.15.2011 , 05:11 PM | #5
I have the same issue for the black screen. Please anyone help us.

reaperkeepet's Avatar

12.15.2011 , 05:11 PM | #6
Just popped it up minutes ago and its pitch black.
Quote: Originally Posted by Darth Baras
The cake is a lie, there is only pie, through pie I gain calories, through calories I gain fat, through fat my belt is broken, the recliner shal free me...

Glaedorn's Avatar

12.15.2011 , 05:12 PM | #7
no i didnt think it could help imma try it now brb

Soliis's Avatar

12.15.2011 , 05:12 PM | #8
Im having the exact same problem as you are. Heres all the info I posted on my thread I started a little while back. Maybe we have a better chance of getting some help i piggyback on your thread.

My thread:

I am aware that there are other threads concerning this situation but I feel the need to start a new one as the others have not been resolved for some people.

The issue concerns going into the game once the client has been closed. The window comes up and I can hear the introduction movie playing in the background. The problem is that there is no video to accompany the audio. I hit escape to skip the introduction and still no video is present. Randomly clicking on the screen produces different sound effects and looking at the AppData folder shows that a server was chosen. Point being that the game is working.. but there is no video or graphics to accompany the game. I can even see the cursor on the screen! However no amount of restarting or fiddling with settings or even the almighty alt+tab maneuver will get the video working.

I have already tried changing the resolution through the .ini files in the installation directory as well as updating my video card and directx11. Basically there is still some kind of issue that the repair function in the launcher does not fix, and I would prefer an alternative to reinstalling the game that may not even fix the problem.

I am using a Radeon HD 4770 with 8GB of ram and a 3.2Hz duo core processor. OS is Windows 7 ultimate 64bit.

Any help would be greatly appreciated.

zellie's Avatar

12.15.2011 , 05:15 PM | #9
dear everyone,

upgrade your video card drivers

Soliis's Avatar

12.15.2011 , 05:16 PM | #10
As said in the reply I have already tried updating my video card driver. there is no new update.