Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Black screen when launching game. Audio and cursor still present. Help please!

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Black screen when launching game. Audio and cursor still present. Help please!
 

Soliis's Avatar


Soliis
12.15.2011 , 04:46 PM | #1
I am aware that there are other threads concerning this situation but I feel the need to start a new one as the others have not been resolved for some people.

The issue concerns going into the game once the client has been closed. The window comes up and I can hear the introduction movie playing in the background. The problem is that there is no video to accompany the audio. I hit escape to skip the introduction and still no video is present. Randomly clicking on the screen produces different sound effects and looking at the AppData folder shows that a server was chosen. Point being that the game is working.. but there is no video or graphics to accompany the game. I can even see the cursor on the screen! However no amount of restarting or fiddling with settings or even the almighty alt+tab maneuver will get the video working.

I have already tried changing the resolution through the .ini files in the installation directory as well as updating my video card and directx11. Basically there is still some kind of issue that the repair function in the launcher does not fix, and I would prefer an alternative to reinstalling the game that may not even fix the problem.

I am using a Radeon HD 4770 with 8GB of ram and a 3.2Hz duo core processor. OS is Windows 7 ultimate 64bit.

Any help would be greatly appreciated.

Sabirwolf's Avatar


Sabirwolf
12.15.2011 , 04:54 PM | #2
I'm having the same problem, but my monitor (a dell) pulls up a little blue box that tells me "the current input timing.." isn't right, and tells me I need to set the current program to display in 1366x768@60Hz, but I'm stuck in a catch 22 of can't do that outside of the game itself.

I made a post asking for help, but it says I don't have permission to look up my old posts o.0

A friend told me to try this: (which didn't help). Program Files>Electronic Arts>Bioware>Star Wars - The Old Republic> swtor>retailclient>client_defaults.txt


I also found mention of another fix that I'm about to try myself. (posting it for you in case it works, cause the game doesn't like to tab out, or in case I can't find this again.

I am having the same problem.

Not sure why, I played in the beta and everything worked great.

Would love some info on this as well.

Searching forums til...

[Edit]
I had to open the defaults.ini and modify the value FullScreen=true to FullScreen=false
▀!Ξ[▀!▀(Θ)▀!▀]Ξ▀!![▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀)

BMGBen's Avatar


BMGBen
12.15.2011 , 04:58 PM | #3
Having the same problems on my laptop, complete joke this is

AndrBu's Avatar


AndrBu
12.16.2011 , 07:23 AM | #4
I have same problems after updating video driver, need to back it up

kwiatek's Avatar


kwiatek
12.16.2011 , 07:36 AM | #5
You have to run it in windowed mode, in order to do that you have to edit a file which is located in:

Star Wars-The Old Republic/swtor/retailclient/

filesname is:

client_defaults

edit it in notepad or whatever

change:

FullScreen=true

into

FullScreen=false

Then you can tamper with settings ingame

Nightkyss's Avatar


Nightkyss
12.16.2011 , 08:41 AM | #6
i had the same issue .. only fix that worked was the 12.1 preview driver

http://support.amd.com/us/kbarticles...iewdriver.aspx

NinjaYeti's Avatar


NinjaYeti
12.16.2011 , 09:42 AM | #7
I had the same problem, but installing the 12.1 preview driver resolved the issue.

Dalien's Avatar


Dalien
12.16.2011 , 11:10 AM | #8
I am running a Radeon HD 3650 and had the same problem. latest drivers and latest DirectX. But once i went into the INI and changed the fullscreen=False it solved the issue. I think this is the best fix. My problem now is the game loads but the server screen is just a big blank blue box. the servers never show up for some reason.

FortisAP's Avatar


FortisAP
12.16.2011 , 11:26 AM | #9
I am having the same issue. I have an EVGA Geforce GTX 260 and updating to the latest driver did not work. Can somebody please explain in greater detail how to open the game up in windowed mode and edit the INI?

Edit - nvm figured it out.

Killabezz's Avatar


Killabezz
12.16.2011 , 12:08 PM | #10
Having the same problem and tried all the ideas so far in thread and nothing works plz help ! AtI HD6770