Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Jindo Krey still bugged in Hard Mode

phattisimo's Avatar

04.08.2012 , 11:29 AM | #11
2nd start fight by sending TWO people to center console one will be harpooned so one will make it to console unscathed
3rd WAIT TILL THE SHIP IS CLOSE!!! it swoops in close to console clik it then! doesnt work 1st time retry (you'll see turret fire)
this fight is a breeze if your console person can take cover/crouch. just setup at console crouch/cover have camera facing ship so you see when it gets close. the crouch/cover nullify's Jindo's harpoon so you'll never move. if Jindo come up on your platform just get tank to pull him off it. GL!!
PS a healer crouched at the center console is ideal he can use party frames to heal targets and keep his focus on what ship is doing/shoot it

Trineda's Avatar

04.08.2012 , 02:22 PM | #12

Hello there,

We saw your thread and thought you might be interested in some of the changes coming in 1.2 in relation to the False Emperor. You can find more information on the 1.2 patch here.

Quote: Originally Posted by AmberGreen View Post

Game Update 1.2 PTS Patch Notes (Continued)

The patch notes published for the Public Test Server are not final and are subject to change.

The following URL will allow you to link to the Flashpoints and Operations PTS Notes directly:

Flashpoints and Operations

The False Emperor
  • An issue that could prevent HK-47 from spawning correctly has been resolved.
  • Fixed an issue that caused the turrets to sometimes fail to damage Jindo Krey's ship. *UPDATED 4/6*

Xzara's Avatar

09.30.2012 , 11:57 AM | #13
Did this re-show it's head again? i've run this instance several times in past. Last night was first time since 1.4 though. We've never had issues at Jindo Krey's ship. This time however after the 3rd shot to the ship, hitting the cannon animated a shot to the ship, but did not interupt the shooting. The control would re-light and allow the click, would send another shot to the ship, but ... still no impact. We tried a few times and always on the 4th shot it decided not to effect it anymore.