Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Locked out of my ACCOUNT


Ragefell's Avatar


Ragefell
12.15.2011 , 10:41 AM | #1
I tried to log into my account, and since I'm at my parents house instead of my apartment it was flagged for a security issue. The security question was "WHat is your favorite movie?." I couldnt remember exactly what I put and from the many combinations of capitals/spaces/and pronouns, my account has been LOCKED. I've tried emailing them, and calling them and still NO RESPONSE 24 hours later. I'm about to get into EGA but I wont be able to log in.

THIS IS COMPLETELY RIDICULOUS. Security questions should not AUTOMATICALLY lock you out of your account without somehow letting you email the attached account or something. I'm very upset with this customer service and the whole security issues. Since when has security questions ever done anything other than lock someone out of their account?

DemonCowz's Avatar


DemonCowz
12.15.2011 , 10:42 AM | #2
Remember your question bro... GL getting through when thousands of people are probably calling about stupid crap like this, lol.

Roerie's Avatar


Roerie
12.15.2011 , 10:43 AM | #3
So basicly you know that Secret question are for security purposes,

You cant remember the answer u put 1-2 month ago.

And now you cry ?

Ayestes's Avatar


Ayestes
12.15.2011 , 10:43 AM | #4
Internet Security is something that is rather important. Especially with MMORPG's where you can traffic a lot of money through the abuse of compromised accounts. It seems a lot of people are pretty bad at remembering their own personal information. You should have your own standardized way of writing as well. I could see forgetting passwords, but Security Questions? Oh well I guess, make your phone call.

Ziborn's Avatar


Ziborn
12.15.2011 , 10:44 AM | #5
try resetting ur password worked for me :P

angrYdog's Avatar


angrYdog
12.15.2011 , 10:45 AM | #6
well why dont you take your time before answering security questions...

its very important...many people just put in some stupid stuff they never remember...

your fault..

Ragefell's Avatar


Ragefell
12.15.2011 , 10:45 AM | #7
Its not that I can't remember the answer I put. I put one of 2 things but i couldn't remember if i added pronouns, capitalized it or put spaces. Also...IT ASKED ME THE SAME QUESTION ALL 5 TIMES. Whats the point of asking us 5 security questions and only using one of them? Its very stupid. At least rotate the questions.

MetroPolice's Avatar


MetroPolice
12.15.2011 , 10:45 AM | #8
Thank goodness i wrote my SQs down on paper and take like 3 minutes in case i'm overdosed on derp so i wont write the wrong thing into it. Be more thoughtful, mah boi. Also they will probably start handling these issues after finishing with today's EGA. My guess anyway.
Where is your Early Access you may ask? I took it. Its that simple.

freekshow's Avatar


freekshow
12.15.2011 , 10:47 AM | #9
Sounds like you should have picked a better security question. Like I don't know, maybe something you would actually remember.

rastaah's Avatar


rastaah
12.15.2011 , 10:47 AM | #10
This happened to me about 10 days ago after the beta weekend and I had to call...thing is it was not during release so I got through and the guy was so so helpful. He told me to write them down and I did!!

With me it was that I had a space between the restaurant name....

So it was Mr. A's and I had it like Mr. As something like that....(its no longer that so is why I can use it LOL)

Anyway.....you get the picture, it has to be EXACT and I think the sec. question is not caps sens like the pw is.