Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

The login service is currently unavailable

STAR WARS: The Old Republic > English > Customer Service
The login service is currently unavailable

windchimepuppet's Avatar


windchimepuppet
12.15.2011 , 10:16 AM | #1
Ive decided to compile a list of things to try and fix this because i have been trying for 3 days straight without doing anything else but this.

Basically when you download and install the launcher client, once you open it you run into a red bar above the log in info and it states, "The login service is currently unavailable. Please visit our forums for the latest updates on the status of this service." Now we all know that the log in service is not actually down at all and this is just a big bug that many are running into. Here are things ive read to fix this and maybe it will help some of you.

- Try installing it in a different directory. i know that some games like morrowind have a problem starting in the default directory so changing that might help.
- make sure you set it to run as administrator by right clicking the launcher and going to properties, compatability and checking it. you can also do this with anything else you would run like the fixlauncher application.
- run fixlauncher. apparently this helps some people.
- make sure you are not blocking the launcher with your firewall or that it is exempt with your virus scanner. i have my firewall ask me if it can have permission and wont go into exempt unless i tell it to. but go ahead and make sure the launcher has full access through the firewall (this process differs per firewall and virus scanner). you can even try to turn off the firewall and virus scanner to see if it is the issue.
- try a different compatibility mode. same place you went to run as admin, most people have it work on windows 7 and windows xp service pack 2.
- reinstall the launcher, but id assume youve tried this a few times already at this point.
- check your router settings. sometimes your router can be blocking it through its personal firewall or maybe you dont have something like open NAT. try changing some of these settings (i recommend googling it and making sure you do it properly).
- direct connect to your modem. take the router out of the problem.
- open the ports.
- sync clock and date with the internet.
- try creating a new user, maybe its a personal setting you have on your user.
- (not recommended) you can try installing it on a different computer and transfer it to yours and try running it, but you still have to use the launcher and it usually runs into the same issue (again, NOT RECOMMENDED).
- reset ip and tcp. From Admin command prompt run. netsh int tcp reset. netsh int ip reset.
- flush your dns. From Admin command prompt run. ipconfig /flushdns
- try clearing your cookies for your browser.
- try doing this in cmd: nbtstat -R. nbtstat -RR.
- some have tried running it in safe mode with networking, but i havent seen this working as of yet for anyone.
- turn off your peerblocker, but i dont know exactly how to do this (anybody with better information on this one would be great)
- the main thing ive read that works apparently is reinstalling windows but i havent tried this. this would be a last resort for me.

there might be some other ways people have tried but i either cant remember them right now or havent read them yet. if you see anything missing just add it. here is what the log is saying if it helps:

20111214160832 INFO -----------------------------(300)-----------------------------
20111214160834 INFO SpecsHash=3294007983.4220189179
20111214160834 ERROR Promos Error status: 5
20111214160834 ERROR Failed login server pping tests.
20111214160834 ERROR Going Offline
20111214160834 ERROR Promos Error status: 5
20111214160834 ERROR Promos Error status: 5
20111214160834 ERROR Promos Error status: 5
20111214160834 ERROR Promos Error status: 5
20111214160834 ERROR Promos Error status: 5
...... (lots more of the same)

i hope compiling everything together in a post will help bioware get the ball rolling on fixing this. any assistance would be much appreciated. thanks everyone.

windchimepuppet's Avatar


windchimepuppet
12.15.2011 , 10:36 AM | #2
- try a disc cleanup on the drive youre installing it on.

mookasabi's Avatar


mookasabi
12.15.2011 , 11:54 PM | #3
I've had this problem since the beta, and I'm starting to get fed up. I just hope they fix it by launch or its going to be a sad waste of $60

Daylor's Avatar


Daylor
12.16.2011 , 12:17 AM | #4
Thank you a bunch the time sync is what did it for me I would not of thought of that!

Again thank you spent too much time trying to resolve that issue