Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Lag in Warzones. Looking For Fix not QQ.

STAR WARS: The Old Republic > English > PvP
Lag in Warzones. Looking For Fix not QQ.

Kon_man's Avatar


Kon_man
02.05.2012 , 04:17 PM | #1
Ok, So I just restarted my sub to give the game one last shot I wanted to be fair and give it a chance. After playing for a few minutes I qued up for a warzone and it popped almost instantly. The first one was Alderaan and though I like this one I couldn't play it. The lag was evident in the first few seconds when I tried to click on the speeder to go down and it took more than 30 seconds to even register and show me leaving.

The second warzone was Voidstar, now this one was not as bad as Alderaan, but the lag was still there and noticeable. It is almost impossible for me to be competitive in Pvp as a Sith Sin and lag like I do.

I am running a Asus G73jh:
Intel quad-core I7 1.6ghz over-clocked to 2.6ghz
8 gigs of DDR3 ram
Ati Radeon Mobility HD 5870
Windows 7 Home Premium 64bit
Comcast 15+mbps connection with a Netgear router

I have reflashed my BIOS and Video BIOS for the ATI issue. Have all drivers updated even tried rolling them back. I have all ports open through my router. No firewall/AV stopping anything. I have tried doing a Clean Boot. Tried using a buddies internet. I have done almost everything I can think of to fix this issue that I only have on this game.

I can play Battlefield 3, Wow, Batman Arkham Asylum with no issues. Company Of Heros, Sid Meier's Civilization V, The Witcher 1 and 2 all max settings with no issues/problems. I can't get over 30 fps on the fleet and load times are horrible going to planets.

I am not a huge PvEr anymore, I don't even like the quest in this game and really just wanted to PvP on my Sin, but due to lag I can't. I normally have 50-60ms on the server and during warzones less than 12 fps.

TL;DR: Y U Lag N Warzones SWTOR? Any suggestions on a fix?

Trigolas's Avatar


Trigolas
02.05.2012 , 04:23 PM | #2
Exactly the same thing here

Windows 7 64 bit
playing on core i7 2.9GHz
AMD radeon HD6650M 2806Mb hyper memory
8gigs of DDR3 ram

like op said can play every game smoothly except swtor where i'm lagging my *** of in pvp 2-10 fps in there while out of pvp i'm having 60-90
plz anyone who can come up with a fix?

RobNightfall's Avatar


RobNightfall
02.05.2012 , 04:25 PM | #3
I've seen posts here and there listing the same problem and citing what the posters consider to be a bug: the game uses our CPUs to process graphics much more than it utilizes our GPUs (graphics cards). I think BW is still working on real optimization of the game so it will play smoothly, but I haven't seen or heard of any comments made by an developers one way or another regarding the lack of utilization of GPUs.
Edited because the devs appear to have fixed at least 80% of the crap that was pissing me off.

Kon_man's Avatar


Kon_man
02.05.2012 , 04:30 PM | #4
Thanks for the replies, I guess I will just wait till they fix it. Hopefully before this month's sub is up so I don't feel like I wasted another fifteen dollars. I will keep my sub if they do, if not I will be looking for a new game to have some Pvp fun.

Any suggestions on a good PvP based game till GW2 comes out?

Trigolas's Avatar


Trigolas
02.05.2012 , 04:32 PM | #5
well both my cpu and gpu should be capable of running this game smoothly I guess. Only thing I can think of that's causing this is a major mistake in their gameengine for pvp and if this would be the case there should be much more people with lagproblems in pvp.

Trigolas's Avatar


Trigolas
02.05.2012 , 04:39 PM | #6
Quote: Originally Posted by Kon_man View Post
Thanks for the replies, I guess I will just wait till they fix it. Hopefully before this month's sub is up so I don't feel like I wasted another fifteen dollars. I will keep my sub if they do, if not I will be looking for a new game to have some Pvp fun.

Any suggestions on a good PvP based game till GW2 comes out?
pvp based game but not an MMO

Blood lines champions and League of Legends

Kon_man's Avatar


Kon_man
02.05.2012 , 04:40 PM | #7
I am thinking it is more of a issue with ATI cards/drivers and this game. As my buddy has the exact same rig as me(different model Asus), but the NVIDA equivalent of my graphics card and runs way smoother than me.

I know it is not my rig, though as I stated before I have no issues with any other games. This and the fact that you are also having trouble with this game and you are also running a ATI card. I wonder how many others that are lagging are running ATI cards.

IWuvKittehs's Avatar


IWuvKittehs
02.05.2012 , 04:40 PM | #8
I had the same problem on my Asus laptop, I used to lagg like crazy in game all the time, not just pvp, all my specs were hood and up to date, It finally got better when I bought a laptop cooler and I run my comp on power saving mode, tho I still have a little bit of fps problems in pvp, it's still playable, and much better than the about 6 fps I used to get.

Kon_man's Avatar


Kon_man
02.05.2012 , 04:48 PM | #9
Quote: Originally Posted by IWuvKittehs View Post
I had the same problem on my Asus laptop, I used to lagg like crazy in game all the time, not just pvp, all my specs were hood and up to date, It finally got better when I bought a laptop cooler and I run my comp on power saving mode, tho I still have a little bit of fps problems in pvp, it's still playable, and much better than the about 6 fps I used to get.
Yes, before my temps would get very high also. I have a cooling pad under my laptop and it is 65f-70f in my house. My temps hoover around 80C hardly ever gets higher than 85C now. I have cleaned all vents and fans inside the laptop and it has good airflow.

Trigolas's Avatar


Trigolas
02.05.2012 , 04:54 PM | #10
yep seems to be a problem with ati cards
altho cant rly find a fix that works for them tried in ccc to set priority's higher and hat only helps a little. still having major lag problems ^^