Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Error Code 4001

First BioWare Post First BioWare Post

OwenBrooks's Avatar


OwenBrooks
12.08.2013 , 10:23 PM | #21
4001 is a communication error (can be followed by 9000 and game close), so these people back in June wont be the only ones to get it., being in the IT field you should recognize this.

if lots have it at once then net issue or server issue is more likely, one person would point more to a local issue and AV and Firewall is the best places to check for launcher.exe and swtor.exe

Ragetacular's Avatar


Ragetacular
12.30.2013 , 04:10 AM | #22
I was deployed for ~6 months but started playing again the last couple weeks. Been getting 4001 randomly, but I don't remember this being an issue before I left.

Trusienko's Avatar


Trusienko
02.15.2014 , 08:09 PM | #23
Yeah I've been gettin that 4001 error code a lot too. But it does more then just boot me out the server. It also closes the SWTOR game on me as well. So I have to re-boot the game and re-enter my server. I'm posting this on 2/15/2014 and I'd say just today alone it's done this about 4 or 5 times. Would be cool to find out what the issue is. I was about to start tinkering with my security settings and firewalls, even run a tracert... until I read this forum and saw all the other people having this issue.
Bioware, please help to fix this, even if it's on our end.

Thank you.

Edit: Oh and I haven't had this problem before, it just started doing this to me today (note: I have not updated my firewall or security or microsoft files between now and the last time I played). So I know it isn't my firewall. Of course I know computers well enough to know that it also could be the firewall and now all of a sudden it's deciding to block SWTOR. But usually it doesn't just happen on it's own. So iunno. Any help will be much appreciated.

THoK-Zeus's Avatar


THoK-Zeus
02.21.2014 , 08:24 AM | #24
Same Error Code (4001), started today for the first time.

No changes on my firewall, or on my Computer. I have all the firewall exceptions.
Reconnecting, fixlauncher... does not work.
It's definitly on Bioware's end.
Zahik - DiLiH - The Red Eclipse

VictorBearwolf's Avatar


VictorBearwolf
02.21.2014 , 10:18 AM | #25
Same here.
Vi Kot'tor!

Lesandro's Avatar


Lesandro
02.21.2014 , 10:39 AM | #26
Same problem. After restarting computer I got 208 problem.

Wintermole's Avatar


Wintermole
02.21.2014 , 10:56 AM | #27
I thought i am the only one with that problem, when i login into game i have empty server list and that error 4001. Tried all solutions in sticky, but it didn"t helped. This is strange because my guildmates in the game atm.

MrGopher's Avatar


MrGopher
02.21.2014 , 12:55 PM | #28
I have this problem right now. I was trying every advice from similar forum threads (including yellow posts) and nothing have changed. I realy hope this problem will fix itself, because i dont know what else I can do.
I hope this information from client log file will help.

2014-02-21T22:50:23.349799 0C801838 INFO Login user: MrGopher shardaddress: @:: [Client.Startup](playerclient.cpp:PlayerClient::Login:1908)
2014-02-21T22:50:29.220135 0C801838 INFO Renderer using 24-Bit Depth Buffer. [Client.Renderer](dx8cs_services.cpp:`anonymous-namespace'::RendererLogMessageHandler:513)
2014-02-21T22:51:02.208022 0C801838 ERROR Invalid response received from platform for getShardList request. Status code: 0 [Platform.dozerLib.dozer.ClientServices](clientservices.cpp:bwa:latform::ClientServices: :receivedShardList:191)
2014-02-21T22:51:02.208022 0C801838 WARNING HandlePlatformFailure with error type 4001 : PLATFORM_ERROR_EMPTY_SHARD_LIST [Connect.firestorm.client.OmegaClientApp](omegaclientapp.cpp:OmegaClientApp::HandlePlatform Failure:501)
2014-02-21T22:51:02.738052 0C801838 INFO [Client] Active area load complete [Client.AreaManager](bwaareamanager.cpp:bwa::AreaManager::_onActiveAre aLoadComplete:872)
2014-02-21T22:51:46.733569 0C801838 INFO RemoteRenderer process shutdown complete. [Client.Shutdown](dx8_basic.cpp:OSShutDown:2453)

Archmano's Avatar


Archmano
02.21.2014 , 01:18 PM | #29
same problem - no solution
No Change in Hardware, Software, Antivir or Firewall. Everything else works great but
SW TOR just shows me empty server lists...

Markag's Avatar


Markag
02.21.2014 , 08:56 PM | #30
I randomly get the 4001 error as I log in, just as I get to Character Select. if I click more information, I am able to double click on my character and enter the game. However, the error code is still there when I log to character select again. Seems this problem re-surfaced with the last patch.