Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Missing codex entries


Barbarosa's Avatar


Barbarosa
02.03.2012 , 05:45 PM | #1
Not sure how obessive compulsive others are but, story and lore's a big part of the game experience for me and I've noticed that a lot of obvious lore pieces that should pop don't making folks who are a bit OCD a little nuts. For instance, the Revanites organization Codex entry doesn't pop during the Revenite quest line. Sure, this could be because the pop is keyed to very specific answers in the dialog of the quest, which frankly seems really stupid since it narrows down who can or can't finish all of the DK codex entries to a very narrow few who get very, very lucky. And it leaves others wondering ***? I ran everything, where's the stupid codex entry? It deminishes the game experience.

Caelambulator's Avatar


Caelambulator
02.03.2012 , 09:34 PM | #2
I'm with you there. For the first 5 planets I went through, I tried really hard to complete all the codex entries for each planet. By the time I got to the 6th planet, I was getting really discouraged about the whole codex thing and realizing how broken the codex was, so broken that not a single planet could be completed. Each time I logged on I was excited about getting new codex entries. The excitement has worn off.

It may seem like an exaggeration to some, but if it turns out that the many of codex entries are either intended to be unobtainable or that bioware is just not going to bother fixing them, I will probably end my subscription. Finding them all was a really big part of my initial excitement about the game.

decrypter's Avatar


decrypter
02.03.2012 , 09:42 PM | #3
Bump a lot of people love completing planets etc needs fixing asap

Aphid's Avatar


Aphid
02.03.2012 , 09:50 PM | #4
Same thing has happened to me. Satele Shan did not update in my Codex after completing the opening quest line. I put in a ticket and the thing that responded told me it was working as intended. Pretty dumb stuff if you ask me, so basic and such an old-school problem. The thing that responded to my ticket was completely clueless. I was embarrassed for them, for their poor command of English, their inability to understand my basic problem, and the two-week time period ithey took to respond.

It's weird to find a problem with something, report the problem, and then to be told by the person who would fix it that there is no problem. Maybe the Fed runs SWTOR.

ialyxxiieee's Avatar


ialyxxiieee
02.04.2012 , 07:14 AM | #5
Yes, I have an ocd like that aswell. I got bored and decided to clean planets of all objectives in ascending order, so i decided to go back to my first planet and half the codex entries are either broken or unavailable +many entries have either been changed or missed from the beta.


I would call my self a "completionist" the only way i'll be happy is if Everything is done.

anyway Im sure Bioware will fix it...hopefully NOT NEXT YEAR!

preaCor's Avatar


preaCor
02.04.2012 , 04:56 PM | #6
bump!

Dreadlords's Avatar


Dreadlords
02.04.2012 , 09:12 PM | #7
bummmmmppppp

Acrolepsia's Avatar


Acrolepsia
02.05.2012 , 09:41 AM | #8
Bump. This annoys me too.

Barbarosa's Avatar


Barbarosa
02.10.2012 , 06:13 PM | #9
Add in that titles that should pop aren't. If you start on Koriban, and don't immediately go around everything to get to the academy, you don't get the Sith Academy. It's just plain stupid. Small, easily missed datapads that can be found later, that's one thing. But, this is just play annoying.

ialyxxiieee's Avatar


ialyxxiieee
02.11.2012 , 01:03 PM | #10
Plainly ...im a completionist, bioware if you do not sort out the codex soon. i will take my own life , thank you .