Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

warning- do your planets in order * SPOILERS*

STAR WARS: The Old Republic > English > Classes
warning- do your planets in order * SPOILERS*

Crezelle's Avatar


Crezelle
01.31.2012 , 08:29 PM | #1
been waiting for my ticket to resolve for 2 days now. can't finish act one now.
heres what happened:

Had a friend plow me along alderaan so i could ditch kaleiyo and i could fraps vector's dialogue in tatooine ( he has some, but not a lot, and very few, if at all affection gains)

whats wrong?
I cannot finish the tatooine quest by talking to watcher 2 on my holocom, instead she just talks about the up-to date stuff after alderaan. I go to the place where i finish act 1, atrus i think? and i talk to her, and she says we gotta fly to where we are. no cutscene or anything. and all the doors are locked.

this stinks.

CPJugg's Avatar


CPJugg
01.31.2012 , 09:27 PM | #2
This broke for me on 1/7/2012. I put a ticket in then. They immediately closed it and sent some half-a**ed e-mail about what to try which any moron would have tried before submitting a ticket.

I submitted another ticket a week later. I submitted one last week until someone in-game person sent me a message saying it was being escalated. Today, a week later now, still nothing.

Add on top of if that the Operative got nerfed today and I am having a great time in SWTOR. Real close to cancelling. You should just go ahead and re-roll a better class now.

Crezelle's Avatar


Crezelle
01.31.2012 , 09:28 PM | #3
eh...managed to get someone on the phone who hooked me up with a live chat agent.. they told me to log off, so im here now.

who knew vector would give my game a bug * rimshot*

CPJugg's Avatar


CPJugg
01.31.2012 , 09:33 PM | #4
Let me know if it gets fixed. I will be even more pissed. I called the customer service number. It seemed like only 1 phone tree gave a live person. He said he couldn't help me. The usual 'my system has no access to that part of the game'. True statement but still provided me no other alternative. I asked what the escalation process was and he said to submit another in-game ticket. So submit a ticket through the same mechanism that is not working. Sweet.

Crezelle's Avatar


Crezelle
01.31.2012 , 09:40 PM | #5
i gave the " poilite and apologetic, i understand things are hectic over there, but im quite stuck and have been waiting for days and am getting VERY impatient" approach

they said they are removing me from the quest.... i wonder if that means i have to do alderaan and tatoo all over again. if so i better not have reset affection for vector. i got him to 2700.
i wonder how long i have to wait out here.... meh.

Azkit's Avatar


Azkit
01.31.2012 , 11:45 PM | #6
Did you reset the quest? Ya didn't exactly tell us what you've tried, so I have to ask.
NIGHTMARES ASYLUM
Server: Hedarr Soongh
Kara Gunn (Op) - | - Ray Gunn (Merc)

Crezelle's Avatar


Crezelle
02.01.2012 , 02:14 AM | #7
i reset the quests..no luck...
and im still in queue..all that being passed around from one manager to the next.... all they said is im in the top priority tier.... /sigh

time to roll an alt...or clean my house..
darnit vector, look what you did! im making you run around town behind me naked for a week

Mikkeos's Avatar


Mikkeos
02.01.2012 , 04:38 AM | #8
That usually means that you wont progress on the class quest from this point on - at all.

It happened to 2 friends of mine before, one of them a bounty hunter.
I hope they found a way to get the previous quests working for us again.
Q: So, is there anything at all in the game that mitigates falling damage?
A: elevators

Chatokun's Avatar


Chatokun
02.01.2012 , 06:19 AM | #9
There's a work around. Reset your class quest that has you going to the Atrus. Talk to Darth Whatshercrazyface again, and when you get to your ship, do not touch your holoprojector whatsoever.

Go straight to Atrus, and talk to Watcher 2, she should give you cutscene with the same dialog you'd have heard if you used the holo, but it's really supposed to be here in the Atrus.

I did the same thing as you and was stuck for a while, but I found a threat stating the above, and now I'm far past it.
Jedi Knight Wannabe
...and Operative it seems, yay!

Zapher's Avatar


Zapher
02.01.2012 , 06:54 AM | #10
I also made the same 'mistake' (doing Alderaan first to get a better companion) and ended up with the same problem.

However, I did something very similar to the reply above me (by Chatokun) which allowed me to progress but also left me with a very strange problem.

I'm now level 50 with a completed story quest, but I still have the grey level 28 story quest "The Assassin's Fortress" in my quest log even though I've already completed it.

Part of me is curious if I'm able to replay the class quest by going back to Tatooine, but I don't want to somehow screw up my character if/when a story update is released, so for now I'm just leaving it alone.