Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Low FPS..... Very low actually

 

Kameis's Avatar


Kameis
12.15.2011 , 04:51 AM | #1
Im running the game on a laptop:
Inter Core Duo P7450 2,13 GHz
4GB RAM
ATI Mobility Radeon HD 4570
Windows 7

My FPS are around 5-12 on all Low graphoic settings, it really sucks... Now the thing is that I played the beta ( on 25-28 november and the final beta weekend in December) and my FPS were 20-40 on HIGH texture details and HIGH model graphic details. Grass was on 30% and trees were also on 30%. I did not have any FPS issues at all during the beta with those settings so my question is why is the game nearly unplayable for me now? (now I have all set to low and grass/tress set to 0.... nothing helps.)
JEDI MASTER KAMEIS

My saga began: 14 December 2011
Tester: 25-28 November 2011 Beta Test Weekend & 2-4 December Final Beta Test Weekend

GigasFist's Avatar


GigasFist
12.15.2011 , 04:55 AM | #2
The game absolutely hates ATI cards.
Make sure to turn off Shadows and have everything set to low. Shadows are what seem to destroy framerate.

Kameis's Avatar


Kameis
12.15.2011 , 04:57 AM | #3
Quote: Originally Posted by GigasFist View Post
The game absolutely hates ATI cards.
Make sure to turn off Shadows and have everything set to low. Shadows are what seem to destroy framerate.
Were already turned off, doesnt help I assume that Bioware upgraded the graphics of SW TOR before early access and my lapton can no longer handle it... Is there a way to change some additional graphical settings except those in graphic options.. or maybe dowload a "special" client for noob PC's? ^^
JEDI MASTER KAMEIS

My saga began: 14 December 2011
Tester: 25-28 November 2011 Beta Test Weekend & 2-4 December Final Beta Test Weekend

Nubacat's Avatar


Nubacat
12.15.2011 , 04:59 AM | #4
Turning shadows and bloom off, seem to be the norm for most people. If that doesn't work its probably the expensive option.

Amarinth's Avatar


Amarinth
12.15.2011 , 05:01 AM | #5
1. if you updated from a BETA client, uninstall that and download the retail version. Updating from Beta -> Retail seems to bugger performance.

2. if you start the game it will default to low settings, but many people have found those defaults give rubbish performance (which suggests they're buggered somehow) - try upping the settigns to all high's first, then hit apply, then lower them again.

3. as suggested, turn off shadows - they seem to have changed the lighting/shadows since the last beta, they now play nice with Vsync (at least for me) but on the flipside they now seem to be much more intensive, with your card it's better to disable them completely
We all have our heroes. And when we watch them fall, we die inside...

Kameis's Avatar


Kameis
12.15.2011 , 05:33 AM | #6
Quote: Originally Posted by Amarinth View Post
1. if you updated from a BETA client, uninstall that and download the retail version. Updating from Beta -> Retail seems to bugger performance.

2. if you start the game it will default to low settings, but many people have found those defaults give rubbish performance (which suggests they're buggered somehow) - try upping the settigns to all high's first, then hit apply, then lower them again.

3. as suggested, turn off shadows - they seem to have changed the lighting/shadows since the last beta, they now play nice with Vsync (at least for me) but on the flipside they now seem to be much more intensive, with your card it's better to disable them completely
Setting all details to High, hitting apply and then setting all to Low did the trick! OMG I can;t believe it. I LOVE YOU MAN! I WOULD SO KISS YOUR FEET RIGHT NOW. THANKS A LOT!

Now I can play the game on high settings again smothly!
JEDI MASTER KAMEIS

My saga began: 14 December 2011
Tester: 25-28 November 2011 Beta Test Weekend & 2-4 December Final Beta Test Weekend

Eginhardt's Avatar


Eginhardt
12.15.2011 , 06:55 AM | #7
Quote: Originally Posted by Kameis View Post
Setting all details to High, hitting apply and then setting all to Low did the trick! OMG I can;t believe it. I LOVE YOU MAN! I WOULD SO KISS YOUR FEET RIGHT NOW. THANKS A LOT!

Now I can play the game on high settings again smothly!
http://www.swtor.com/community/showthread.php?t=22757

Try this with your card.
"Call me old-fashioned, but I prefer my fantasy RPG characters not be wearing assless chaps."
"Young girls are told you have to be the delicate princess. Hermione taught them that you can be the warrior. - Emma Watson"

Blitzo's Avatar


Blitzo
12.15.2011 , 06:57 AM | #8
ATI Mobility Radeon HD 4570 is a REALLY low end card

GermGerm's Avatar


GermGerm
12.15.2011 , 04:40 PM | #9
Quote: Originally Posted by Amarinth View Post
1. if you updated from a BETA client, uninstall that and download the retail version. Updating from Beta -> Retail seems to bugger performance.

2. if you start the game it will default to low settings, but many people have found those defaults give rubbish performance (which suggests they're buggered somehow) - try upping the settigns to all high's first, then hit apply, then lower them again.

3. as suggested, turn off shadows - they seem to have changed the lighting/shadows since the last beta, they now play nice with Vsync (at least for me) but on the flipside they now seem to be much more intensive, with your card it's better to disable them completely
This ^^ help me a lot. Thanks

Everyone should try this if they are having fps issues, I could hardly move inside. And I tried this and it works perfectly fine now

Cobero's Avatar


Cobero
12.15.2011 , 05:06 PM | #10
Quote: Originally Posted by Amarinth View Post
1. if you updated from a BETA client, uninstall that and download the retail version. Updating from Beta -> Retail seems to bugger performance.

2. if you start the game it will default to low settings, but many people have found those defaults give rubbish performance (which suggests they're buggered somehow) - try upping the settigns to all high's first, then hit apply, then lower them again.

3. as suggested, turn off shadows - they seem to have changed the lighting/shadows since the last beta, they now play nice with Vsync (at least for me) but on the flipside they now seem to be much more intensive, with your card it's better to disable them completely


This worked for me as well (step 2), Averaging 12 fps with I7-2600k, 8gb ram, and a 4870 1gb. Now I am sitting at 60 stable. I just canceled my 570gtx. You just saved me $350. I owe you a freaking 6-pack. THANK YOU VERY MUCH!!!!!!!