Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

In Game Issue... Print Screen or any other key binding not working for Screenshots.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
In Game Issue... Print Screen or any other key binding not working for Screenshots.

SakaNoviia's Avatar

12.15.2011 , 12:18 AM | #1
I know this doesn't seem like much of a big deal and well it probably isn't.

I was going to take screenshots for my blog only too find out no matter what I do it wont record my photos and create a screenshot folder.

At first i wondered if it was because i was running the game from the Nov 25 launcher but i had a friend test it and he was able to take a picture no problem. I had my husband do it on his computer because he downloaded the new launcher but it doesn't work for him as well.

So now I'm wondering if its an IP issue or if its a common thing that's happening to other people to? It would be nice to be able to take the screen shots but until we figure out whats going on ill just have my friends take pics for me and ill use those for the blog for now.

SakaNoviia's Avatar

12.15.2011 , 12:31 AM | #2
If it helps any, i spent im not even sure how long looking through the preferences to see if i missed something to turn on i went through key bindings and changed the binding 3 times, and i re logged. I made sure to check every folder in my star wars folder multiple times just to make sure i wasn't over looking it. I

probably spent way to much time in game and out of game on the issue but i would like to see it fixed or find a way to fix it.

SakaNoviia's Avatar

12.15.2011 , 01:05 AM | #3
I would like to add running as administrator hasn't worked either along with adding it to my trusted files on my firewall. I'm tempted to run the repair tool but im afraid if i do that my game will stop working or something... and that would be a silly thing to let happen over not being able to take a screenshot.

SakaNoviia's Avatar

12.15.2011 , 02:39 AM | #4
i broke down and decided to run the repair tool but still unable to take screenshots. i think ill go to bed now and try again tomorrow.

swtorment's Avatar

12.16.2011 , 03:32 PM | #5
Just found the screenshots.
If you go to My Documents/Star Wars -The Old Republic/Screenshots
you should find them there. worked for me, anyway.

Chiss Merc.
*DDE Preordered*
Nemo me impune lacessit