Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Redemption issue

viperfm's Avatar


viperfm
12.14.2011 , 11:57 PM | #1
Hi, folks!

Wonder if you could help me out by saying how many redemption codes should i get with the Digital Deluxe Edition?

I've got a code, redeemed it and in the "code redemption history" im getting such a message:
http://clip2net.com/s/1oYY9

But recently in the general account page i've got the following banner:
http://clip2net.com/s/1oYYE
and after typing in my code it says it allready being used...

Have i done somthing wrong or is it some kind of bug?
Cheers.

Rulyen's Avatar


Rulyen
12.14.2011 , 11:58 PM | #2
When you go to 'My Account', then to 'Code Redemption' and scroll down to 'Code History' you should see your already registered pre-order.

The product key will be sent to you by Origin about 16th December.

You also would like to have a look here:

http://www.swtor.com/community/showp...&postcount=499

Thank you.
. Fear teh Beta Pixel!

Maason's Avatar


Maason
12.15.2011 , 12:01 AM | #3
This is the same exact issue that I am having. Pre-ordered thru EA/Origin, have the receipt, redeemed the code, the My Account page shows the code was accepted, but the general pages I haven't redeemed my code.

tried to enter the code using the link on the general page, says that I already redeemed the code. There isn't anything else that I received from EA.

I would understand the problem if this was purchased through some other company...but it shouldn't be this difficult. This needs to be corrected ASAP.

Rulyen's Avatar


Rulyen
12.15.2011 , 12:02 AM | #4
Quote: Originally Posted by Maason View Post
This is the same exact issue that I am having. Pre-ordered thru EA/Origin, have the receipt, redeemed the code, the My Account page shows the code was accepted, but the general pages I haven't redeemed my code.

tried to enter the code using the link on the general page, says that I already redeemed the code. There isn't anything else that I received from EA.

I would understand the problem if this was purchased through some other company...but it shouldn't be this difficult. This needs to be corrected ASAP.
See my post above.
. Fear teh Beta Pixel!

viperfm's Avatar


viperfm
12.15.2011 , 12:02 AM | #5
Thanks alot!

Stepper's Avatar


Stepper
12.15.2011 , 12:17 AM | #6
I've got the same issue. I think its a bug of some sort. But I better be getting early access tomorrow!
/]═══[۞}╦≡≡[‾‾‾}............{‾‾‾]≡≡╦{۞]═══[\
‾┘‾\ΞΞ\............./ΞΞ/‾└‾
\Ξ\........../Ξ/

Rulyen's Avatar


Rulyen
12.15.2011 , 12:18 AM | #7
Quote: Originally Posted by Stepper View Post
I've got the same issue. I think its a bug of some sort. But I better be getting early access tomorrow!
See my first post in this thread. It's not a bug.
. Fear teh Beta Pixel!

Stepper's Avatar


Stepper
12.15.2011 , 12:21 AM | #8
Roger that. I looked at your link after posting. Thank you.
/]═══[۞}╦≡≡[‾‾‾}............{‾‾‾]≡≡╦{۞]═══[\
‾┘‾\ΞΞ\............./ΞΞ/‾└‾
\Ξ\........../Ξ/