Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Redemption Code...


Torkie's Avatar


Torkie
12.13.2011 , 08:44 AM | #1
Already starting on a bad foot, i clicked on "My account" then i saw this illuminating page where it said "Ready to play?"... instantly i was filled with joy but it all lasted very little until i got to the mid section of page where it said i must redeem a code to verify with version of SW i have. Turns out my code is already in use?! lol, SWOTOR team seems like you guys have big issues in hand. Please dont let this game flop like warhammer with stupid errors like these... please.
-Ξ▒▓████▓▒Ξ-

FiveDeadlyVenoms's Avatar


FiveDeadlyVenoms
12.13.2011 , 08:46 AM | #2
many people have this same problem as well as me, its obvious someone screwed up.

pudim's Avatar


pudim
12.13.2011 , 08:46 AM | #3
Someone stole your key
You better contact the support ASAP
Call them by phone

Kesai's Avatar


Kesai
12.13.2011 , 08:46 AM | #4
I am having the same problem

RhenApsolon's Avatar


RhenApsolon
12.13.2011 , 08:47 AM | #5
Quote: Originally Posted by pudim View Post
Someone stole your key
You better contact the support ASAP
Call them by phone
Lol, guy's dont do this. There are a ton of posts on this topic, to sum them up. dont worry about it. you will still be able to play. Codes will be sent out/auto updated closer to launch.

jrfitzny's Avatar


jrfitzny
12.13.2011 , 08:47 AM | #6
Same =/

pottedfrog's Avatar


pottedfrog
12.13.2011 , 08:48 AM | #7
It's already been stated - it's a buggy 'ready to paly' page

If you pre-ordered, once you get your email saying you can join you'll be fine - until then don't worry about it.

Midav's Avatar


Midav
12.13.2011 , 08:48 AM | #8
I'm having the same problem as well.
Always remember to pillage BEFORE you burn...
ehh whadaya mean Jedi can't do that?!?

tblader's Avatar


tblader
12.13.2011 , 08:49 AM | #9
Quote: Originally Posted by Torkie View Post
Already starting on a bad foot, i clicked on "My account" then i saw this illuminating page where it said "Ready to play?"... instantly i was filled with joy but it all lasted very little until i got to the mid section of page where it said i must redeem a code to verify with version of SW i have. Turns out my code is already in use?! lol, SWOTOR team seems like you guys have big issues in hand. Please dont let this game flop like warhammer with stupid errors like these... please.
Were you trying to redeem your pre-order code? If you ordered on Origin you dont have your actual registration key yet. it will be in the Physical Packaging of your edition, or via email if you have a digital edition.
JamesT CT-6816 West Texas Squad Leader Star Garrison
Proud Owner of movie accurate ...MK II - ABS Clone Trooper armor ~ $2000, Fiberglass Scout Trooper Armor ~ $1000, ABS Stormtrooper Armor ~ $1500
CE edition? Naw why pay extra for in-game perks when you can be the Imperial

Bjr-R's Avatar


Bjr-R
12.13.2011 , 08:52 AM | #10
I have the same problem when i go to my account they say i didnt activade my pre-code what i already did becease when ik go to pre-order history you can see that i did fill in the code.

but why is there still standing that i dindt fill in the pre-order code and if i want to do it again its says that the code is already used.
always think before you do something.
that solves the problems before they start