Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

BUG: Guard becomes unusable

First BioWare Post First BioWare Post

Manoog's Avatar

02.08.2012 , 02:18 PM | #111
Powertech tank, I have this issue repeatedly when guarding a Sith Sorcerer.

It crops up when the Sorcerer dies(even if it's a wipe and everyone dies), but sadly it doesn't happen every single time so I can't give you all the variables. It's happened on just about every planet, in flashpoints, warzones, pretty much everywhere.

Dezzi's Avatar

02.08.2012 , 07:02 PM | #112
Juggernaut trying to guard a Mercenary. It will work fine, then at some point (it's hard to gauge when), I'll notice that guard isn't up (no icon on me or the merc). When I go to re-up guard, it gives me the error that it's already applied.
Ebon Hawk (RP)
Peace | Knowledge | Serenity | the Force
I'm a Jedi because the galaxy needs Jedi.

braf's Avatar

02.09.2012 , 01:33 AM | #113
Vanguard guarding a Sage here. Frequent issues with not being able to apply guard, particularly in warzones after dying, etc. Just adding my classes to the list.
Darth Maserati Vulgaris

Aythful's Avatar

02.09.2012 , 09:49 AM | #114
I currently have a Sith Assassin at level 17 that is having annoying issues with the guard when I put it on my droid companion.

For unknown reasons, it constantly comes off him. This could be because he has a tendency to unsummon himself when I enter or exit areas or get on mounts/quick travel.

I would appreciate any fixes to this in the future so that my guard stays on my companion until I dismiss him or my companion stays out when summoned unless I dismiss him. I actually just stopped using it on him because of this issue. Take your time, just please know that the issue for me, exists.

Anchorhead // Empire // Dark Lords of the Sith // Asidious

SGMRock's Avatar

02.09.2012 , 02:37 PM | #115
I had this bug last night on my Vanguard. I had Guard on someone in my party and we had a conversation cutscene in Kaon on Hard Mode. After the conversation cutscene guard was no longer on the person and I could not put it on them because it said they already had it. I tried to put it on someone else and that worked fine, then tried to put it back on the original person and still said they already had it.

I tried to reload the UI and that did not fix it.

Later in the flashpoint we all died and afterwards I could place it on him again. This person was a Shadow Jedi btw incase you need to know that.

Hope this helps.

Elrinia's Avatar

02.13.2012 , 09:50 PM | #116
Shadow tank guarding a sage.

I think this happens if the Sage leaves the zone then re-enters. This could be through death, or the sage just walking out.

Solabysz's Avatar

02.14.2012 , 05:24 AM | #117
Anyone who can guard has probably seen this happen. For me it's usually when guard is repeatedly applied and removed for whatever reason...

Elsebet's Avatar

03.05.2012 , 08:34 PM | #118
Level 30 Guardian, happens often when guarding a level 30 Sage. We have a level 50 Scoundrel/Vanguard and my boyfriend who plays the Vanguard says guard bugs out on him also in similar fashion.

Also this might be related since they are both beneficial buffs. The Sage's Force Armor bugs out when applied on me, where it says "Person cannot benefit from this effect right now".

We can reproduce the Force Armor bug:

1. Sage puts shield on me.
2. I enter an instance.
3. Once we are in the instance, I cannot be shielded again until one of us logs off.

For this reason we don't enter instances until my shield expires.

AmoralCynic's Avatar

05.03.2012 , 11:30 PM | #119
Just updating and bumping this post; I'm running into this problem with a pair of level 20 Bounty Hunters. I'm in Powertech spec; my friend is in Mercenary. Guarding usually works, but sometimes - seems like it might be related to entering/leaving story zones? - she becomes unguardable. I can guard my companion, her companion, or no one at all.. just not my fellow player.

I have to log out and back in to fix the problem.

AmoralCynic's Avatar

05.03.2012 , 11:36 PM | #120
... possibly confirmed; just happened as I left a Group instance with my friend guarded. Upon exit, the "guard" bubble effect stopped showing. When I removed the Guard aura from my bar and tried to re-guard her, instantly received "target is already guarded".