Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

"Swtor launcher has stopped working"

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
"Swtor launcher has stopped working"
 
First BioWare Post First BioWare Post

Sparze's Avatar


Sparze
12.14.2011 , 09:30 PM | #1
I didnt get my early access yet but I cant even open the launcher I try and double click on the launcher and it just says "Swtor launcher has stopped working" i press cancel it comes up again and then just eventually goes away

Should I redownload the game client

Emeralddragon's Avatar


Emeralddragon
12.14.2011 , 09:32 PM | #2
repair the game client. don't waste more bandwidth.

But first try running as Admin.
or try running it in windows XP SP3 compatibility
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."
-Albert Einstein

Sparze's Avatar


Sparze
12.14.2011 , 09:47 PM | #3
Where is the repair? and I ran it in windows XP service pack 2 i dont have sp3

Sparze's Avatar


Sparze
12.14.2011 , 09:55 PM | #4
anyone?

Sparze's Avatar


Sparze
12.14.2011 , 09:58 PM | #5
......

Sparze's Avatar


Sparze
12.14.2011 , 10:29 PM | #6
can someone please help me..................

Smaois's Avatar


Smaois
12.14.2011 , 10:32 PM | #7 This is the last staff post in this thread.  
Quote: Originally Posted by Sparze View Post
Where is the repair? and I ran it in windows XP service pack 2 i dont have sp3
Greetings All,

Please go to www.swtor.com/download and download the setup file again and run it.(Please run the file as Administrator and add an exception for SWTOR_setup.exe to your firewall and anti-virus software).

This will reinstall the Launcher, it will not download the game content again.

We also recommend that you have the latest Service Pack and Windows Updates installed for your operating system, including the optional updates such as .NET framework and Visual C++ features.

We hope this resolves the issue for you!

Smaois | BioWare Customer Service Forum Support

rbSmitty's Avatar


rbSmitty
01.16.2012 , 01:37 PM | #8
I have the exact same issue. I tried the above mentioned method and I've been Googling for 2 hrs trying different things, nothing worked. No matter what I do the launcher will NOT LAUNCH!

I even tried EVERYTHING here... nothing
Quote:
Launcher Doesn't Appear / Just Won't Start

When the launcher first starts, the UI won't appear until its finished a few things. As a result, if the launcher freezes up on you at start, you won't see anything appear at all. You will still see launcher.exe in your Task Manager process list, however.

Some folks have said that allowing the launcher to sit for 10-15 minutes actually allows it to finish whatever its trying to do and recover this situation (the long wait) apparently arises most often with college campus proxies that are automatically assigned in Internet Explorer via a PAC file, where not all proxies play nicely with the launcher.

If, however, even waiting around doesn't work for you, there's a couple of things you can try beyond just the usual 'run FixLauncher, or try re-downloading and re-running SWTOR_setup atop your existing install' solution.

Firstly, check if there is a "patch" directory under your SWTOR install. If there is, the launcher may have died partway through checking on patches delete that directory and things should work. You can also run SWTOR_setup.exe again to be sure that you have a complete/good copy of the launcher. As noted above, that won't overwrite any game data you've downloaded, just will repair the launcher. If this happened, you may have a partial patch from an earlier beta build of the game. Bioware CS notes that uninstalling and reinstalling in such a case may be the best way to ensure you run clean.

Second, if you are running a game that uses GameGuard anticheat protection, GameGuard seems to conflict with the SWTOR launcher. In most cases, if you ensure the game's launcher/update tool has been exited, GameGuard will go dormant and you'll be able to play. This means quitting out of launchers for Lineage 2, Aion, etc.

Third, if your antivirus is Avira, some folks have reported that Avira just blocks the launcher from running no matter whether or not you put that in the exceptions list. You might want to try replacing Avira with Microsoft Security Essentials (as MSE is free) and uninstalling Avira just temporarily, to see if that fixes the problem for you.

Fourth, apparently launcher settings have become corrupted for a few folks you can blow away the launcher.settings file in your SWTOR directory and try running again to see if that helps.

Fifth, a couple of folks have been having trouble with the most recent build of the Curse client blocking launcher.exe from starting. Try quitting the Curse client entirely (using Task Manager if you have to) and then run launcher.exe again.

If none of that works, hit up Windows Update and make sure you have the latest .NET updates installed. In addition, make certain that you have the latest build of Java installed.

You can also set the launcher to always run as Administrator go to the SWTOR icon, right-click, pick properties, and check the 'Run as Administrator' option.

Just for clarification, I have the Digital Delux edition and I JUST finished installing it today. I played the game for all of 5 mins (hadnt even gotten done making my character) when the game crashed, or at least it "booted" me from what I was doing. I was sent back to the screen where you select your server..
I didnt try to start again, I exited because I wanted to restart the program/game. (Earlier I had used alt+tab to switch from the game to my browser because I kept hearing Facebook notifications and wanted to close it. Upon switching back to the game tho it wasnt full-screen anymore, there were 2 HUGE black boarders on both sides of the screen. I even went into the settings and made sure it was on full-screen, not windowed or whatever else. I wish that would be fixed as well.)

Anyway, when I launched the game again, from the shortcut on my desktop, it didnt work, and hasnt since...
I ran the FixLauncher
I reinstalled the client
Ive restarted my computer
Im running it as admin
...nothing

PLEASE HELP!!