Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Much Lower FPS from Beta to Release?

STAR WARS: The Old Republic > English > Customer Service
Much Lower FPS from Beta to Release?

BladeDArk's Avatar


BladeDArk
12.14.2011 , 08:47 PM | #1
I played the beta in both stress test, the near open beta, and once before on a separate account, and throughout all that testing i never had a complaint about the FPS or Input delay or anything that actuialy makes combat slower or less possibly for me. But with the release of the game Ive been completely unable to do pvp because my fps seems to be at about 5-10, and im only able to quest or do flashpoints with friends who know about the issue, because if Im in a pug group, they believe im being lazy when im actuially just unable to play the game properly because of lack of FPS.

Currently running lowest settings on everything in fullscreen windowed, and its owning me still D:

Has anyone experienced a similar issue or can help me out with this?

TLDR - Low FPS that wasn't there during the beta or stress test beta. Happens at all times not just in high pop areas.

Specs-
4Core 3.2ghz/core CPU
8gb Ram
70gb Free HDD space.
HD Radeon 5450 (Used this same card during the testing)

BladeDArk's Avatar


BladeDArk
12.14.2011 , 08:54 PM | #3
testing now, will edit with jawa-hugging-ness if it works

BladeDArk's Avatar


BladeDArk
12.14.2011 , 09:00 PM | #4
I think yours is a bit newer then mine, I dont have some of the places your telling me to navigate to. Graphics Properties was not an option, and when I went into catalyst properties i came to AMD Vision Engine Control Center, and the power menu on the left side there has nothing like what you described.

Eginhardt's Avatar


Eginhardt
12.14.2011 , 09:04 PM | #5
You can also try putting all your settings on high but turning off shadows. Worked perfectly for me.
"Call me old-fashioned, but I prefer my fantasy RPG characters not be wearing assless chaps."
"Young girls are told you have to be the delicate princess. Hermione taught them that you can be the warrior. - Emma Watson"

BladeDArk's Avatar


BladeDArk
12.14.2011 , 09:07 PM | #6
Quote: Originally Posted by Eginhardt View Post
You can also try putting all your settings on high but turning off shadows. Worked perfectly for me.
Testing now o.o

Edit - Helped a bit, its not AS bad, but its still difficult to do anything, and nothing like the FPS i had in the beta D: Ty for your help though.

Sparta_'s Avatar


Sparta_
12.14.2011 , 09:15 PM | #7
Keep it bumped im having the same problem using a Radeon HD 4350
I should be sleeping.

BladeDArk's Avatar


BladeDArk
12.14.2011 , 09:16 PM | #8
Quote: Originally Posted by Sparta_ View Post
Keep it bumped im having the same problem using a Radeon HD 4350
Do try that shadow suggestion, it did help me quite a bit, but when trying to get into PVP, every moment counts, and missing alot of them because of FPS doesn't work lol.

Eginhardt's Avatar


Eginhardt
12.14.2011 , 09:17 PM | #9
Quote: Originally Posted by BladeDArk View Post
Do try that shadow suggestion, it did help me quite a bit, but when trying to get into PVP, every moment counts, and missing alot of them because of FPS doesn't work lol.
You can also turn Bloom and conversation depth off too Blade. I went from 2 fps to 25.
"Call me old-fashioned, but I prefer my fantasy RPG characters not be wearing assless chaps."
"Young girls are told you have to be the delicate princess. Hermione taught them that you can be the warrior. - Emma Watson"

BladeDArk's Avatar


BladeDArk
12.14.2011 , 09:18 PM | #10
Quote: Originally Posted by Eginhardt View Post
You can also turn Bloom and conversation depth off too Blade. I went from 2 fps to 25.
Been done that >.< i went from 3 to 5 fps lol