Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Camera Sensitivity is Out of Control

STAR WARS: The Old Republic > English > New Player Help
Camera Sensitivity is Out of Control

Wapner's Avatar


Wapner
12.15.2011 , 09:50 AM | #41
Quote: Originally Posted by Brainstormz View Post
Where are the extra mouse options in the full release ? i hate mouse acceleration.
The mouse is over accelerating, that is 100% the cause of this. What is causing the over-acceleration is the question. Since it seems to be a minority of people that are experiencing the issue, it has to be some combination of software or hardware and the game not liking that combination, that is causing it.

If there was a "use raw mouse input" checkbox, that seem to be fairly common in newer games now days, it would probably fix the issue.

Malus_Rex's Avatar


Malus_Rex
12.15.2011 , 10:25 AM | #42
I have exactly the same problem with my generic wireless logitech mouse. Don't think the mouse makes a difference but something is badly wrong with using a mouse to move.

Trying to run through doorways and such can cause a lot of problems!
Azrael
Jedi Sentinel
Lightside
Collectors Edition

Zlodo's Avatar


Zlodo
12.15.2011 , 10:35 AM | #43
Quote: Originally Posted by Wapner View Post
Actually if you look at the two videos posted, you'll see that the mouse sensitivity slider is gone (unless it's moved to some hidden area) and I have the camera set at 0%. In addition, I stated on the second page, that I tried various windows mouse pointer speed settings. When that didn't work, I went back to default.

Thanks for the tips, though.
Ok, I now have access to the game and indeed the mouse sensitivity option is gone (I'm actually starting to wonder whether it was actually there in the first place or if I did just remember stuff from some other game).

However it still seems ok for me, even at 5600 dpi with the camera at 0% speed (which the game seems to revert silently to 1% actually) it was a bit too fast but usable.

I have no idea what would cause the difference. I tried to enable or disable vsync to see if it had any effect, it didn't.

The only thing I can think of might be if you have enabled acceleration in your razer profile. I haven't. I tried with it and it didn't seem to make a lot of difference but maybe it's handled differently on the naga than on the lachesis.

I've been doing my tests on a rather crap pc here at work but in the beta it was also fine on my much better pc at home, so I don't think framerate is a factor either.
Eleris, Jedi Shadow, Lord Calypho
If you ever find yourself in a fair fight, your tactics suck.

theangryintern's Avatar


theangryintern
12.15.2011 , 10:37 AM | #44
I have a Logitech mouse and I have it on the middle DPI setting and I dropped the camera rotation down to about 3 and it seems fine for me. Was a bit fast at first but I found I quickly got used to it.

Wapner's Avatar


Wapner
12.15.2011 , 10:50 AM | #45
Quote: Originally Posted by Zlodo View Post
Ok, I now have access to the game and indeed the mouse sensitivity option is gone (I'm actually starting to wonder whether it was actually there in the first place or if I did just remembering stuff from some other game).

However it still seems ok for me, even at 5600 dpi with the camera at 0% speed (which the game seems to revert silently to 1% actually) it was a bit too fast but usable.

I have no idea what would cause the difference. I tried to enable or disable vsync to see if it had any effect, it didn't.

The only thing I can think of might be if you have enabled acceleration in your razer profile. I haven't. I tried with it and it didn't seem to make a lot of difference but maybe it's handled differently on the naga than on the lachesis.

I've been doing my tests on a rather crap pc here at work but in the beta it was also fine on my much better pc at home, so I don't think framerate is a factor either.
I despise mouse acceleration, so I disable that in everything possible -- This includes my Razer profiles. The lachesis is pretty much the same sensor system as the Naga/Mamba, so it should be very similar.

Windows 7 has some built in mouse acceleration, and I used the "MarkC acceleration fix" to get rid of that: (http://donewmouseaccel.blogspot.com/...ation-fix.html) But even with that disabled, returning the Windows 7 acceleration to normal, I get the same thing. It's actually worse because it feels like it's multiplicative acceleration at that point. haha

Omisheen's Avatar


Omisheen
12.15.2011 , 10:50 AM | #46
I've been complaining about this issue since beta as well. THIS NEEDS TO BE FIXED.

I have a logitech G700 mouse and it happens wirelessly or wired. I also would like to turn off mouse acceleration please.

Come on Bioware. PLEASE FIX THIS.

I briefly scanned the posts in this thread and I think someone else had this issue too.
In the beta, I used to also have an issue where once in a while my mouse look camera would feel like it was very "heavy". like the camera had "weight" to it. My camera all of a sudden went from waaay to fast to waaaay to slow. It would take a LOT of mouse movemet to start it moving, and then to stop my camera, I had to counter-turn my camera, like firing retro rockets on a spaceship. I could fix this issue by going into options and changing any key binding, but then the issue would come back randomly later.

It hasn't happened so far, but I am only level 13 and just starting questing on Drommund

Wapner's Avatar


Wapner
12.15.2011 , 10:55 AM | #47
Quote: Originally Posted by theangryintern View Post
I have a Logitech mouse and I have it on the middle DPI setting and I dropped the camera rotation down to about 3 and it seems fine for me. Was a bit fast at first but I found I quickly got used to it.
I'm getting more and more used to it (although I have to manually set my mouse DPI to be insanely low when I log into the game, and then back when I log out. It's annoying. Besides that, it seems to freak out at certain times -- In cities it's nearly impossible to control, no matter what the settings, and then the camera will randomly shoot around. Sometimes it feels like the sensitivity randomly decides to add a factor of 500, and the camera just shoots to the extremes (looking up or down) in an instant. Other times, it feels OK, but frustrating at the same time.

I have a big mouse pad for a reason, i like to use broad strokes for mouse movement. With this game, even on ultra low DPI and 1% camera speed, I have to keep my mouse inside of 1/2 an inch.

ScarletBlaze's Avatar


ScarletBlaze
12.15.2011 , 10:56 AM | #48
Quote: Originally Posted by Malus_Rex View Post
I have exactly the same problem with my generic wireless logitech mouse. Don't think the mouse makes a difference but something is badly wrong with using a mouse to move.

Trying to run through doorways and such can cause a lot of problems!

Yea i run into walls and I have a logitech gaming mouse g500. Most of the times in buildings where i not worried about fighting i just walk and it's easier to control.
A southern girl is a girl who knows full well that she can open a door for herself but prefers for the gentleman to do it because it demonstrates a sense of respect. Guild Roleplays: http://republicexplorerscorp.enjin.com/activity
Referral Link: http://www.swtor.com/r/vLlZlR

Corwingeorge's Avatar


Corwingeorge
12.15.2011 , 10:58 AM | #49
i have the same problem, but i have it at 2% and it's fine for me there

Wapner's Avatar


Wapner
12.15.2011 , 11:02 AM | #50
Yesterday I was feeling like this was a very uncommon problem. But today with the posts on this thread, and with the reaction my YouTube videos are getting (I have at least 5 or 6 messages in my YT inbox asking me if I've found a fix), I have to now assume that this problem is far more widespread than I originally thought.

It would be nice to just get a "we are aware of it, we are working on it." Since it persisted through several beta builds, I hope it's on their list. If it's not, and they are just ignoring the people with this problem, the game feels like a waste of money. I'm still sticking to my plan of cancelling my preorder on the 19th if there's nothing being done about this. :/

While it's tolerable at certain times, it is extremely frustrating at seemingly key times during combat. Games that frustrate me, quickly get uninstalled. I don't want to spend $80 just to be hitting the uninstall button in a week.