Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Lag issues

Kalyc's Avatar


Kalyc
01.24.2012 , 03:07 PM | #1
I don't know if this was covered in a previous post, but I just wanted to give you guys my 2 credits worth of input on the lag issue that i know many people have been experiencing when being in a group of 10+. I don't know if it was intentional, but myself, and pretty much everyone ive been talking to experience a huge degradation in gameplay. FPS plummet to 1-5 FPS and the only people not really experiencing this have their graphics cards overclocked. Is there any plans on working on the raid/pvp lag in the works? I think alot of us would be interested in that.

Raehj's Avatar


Raehj
01.24.2012 , 03:21 PM | #2
Quote: Originally Posted by Kalyc View Post
I don't know if this was covered in a previous post, but I just wanted to give you guys my 2 credits worth of input on the lag issue that i know many people have been experiencing when being in a group of 10+. I don't know if it was intentional, but myself, and pretty much everyone ive been talking to experience a huge degradation in gameplay. FPS plummet to 1-5 FPS and the only people not really experiencing this have their graphics cards overclocked. Is there any plans on working on the raid/pvp lag in the works? I think alot of us would be interested in that.
Unfortunately right now I just set everything to low and that takes care of it - however, apparently the patch today significantly imrpoved things.

Also, they are still working on fixing it apparently.

):

Cuddlezz's Avatar


Cuddlezz
01.24.2012 , 04:27 PM | #3
i as well run with all settings on low as possible and the game looks fine, i lag a little bit on trash and the first boss/encounter in kaon and BONETHRASHER is just completely impossible for me, i have a pretty good computer compared to most people/gamers but i cant progress through hardmode karaggas palace becuase i get like 5 fps on the first boss, im currently in the works in getting an ideal graphics card but yeah, I can assume most people dont want to buy a new peice of computer equipment for one boss.

Again, I would just like to say the game runs generally smoothly everywhere ONLY in bonethrasher is the lag absurd, in my experience operations attempting hardmode karagga either hit his enrage time and get destroyed because they have such low framerates they cannot pull adequate damage per second or they get killed by random things becuase they have no idea where they are.

Kalyc's Avatar


Kalyc
01.26.2012 , 01:48 AM | #4
Oi! That's rough!! Shouldn't have to buy equipment. That's what min specs are for...right?

Kirsith's Avatar


Kirsith
01.26.2012 , 02:16 AM | #5
I too had issues with lag and low fps but for the most part I think I seemed to have fixed it after reading multiple places on how to fix it and all those failing.

Apart from having all the in-game settings set to low or off, editing one of the .ini game files will help. So if you check into a folder similar to the one below:
C:\Users\USERNAME\AppData\Local\SWTOR\swtor\settin gs
There should be a file called client_settings.ini

WARNING: I've heard from a few people that editing these types of files could cause the game to no patch later on down the road since something about the patcher has to validate the original game files but yea...

Anyway, I have mine set to the following settings:

[Renderer]
D3DFullScreen = false
Height = 1080
NativeHeight = 1080
NativeWidth = 1920
TextureAnisotropy = 1
Width = 1920
WindowX = 0
WindowY = 0
MeshLODQuality = 1
VerticalSyncState = false
EnableBloom = false
TextureQuality = 0
UseMinSpecShaders = true
doShadows = false
PlantDensity = 100
FarClipScale = 1.
Buckets = 1
GraphicsDeviceId = 1560
doBlobShadows = false
AntiAliasingLevel = 0


[Game]
MoviesFolder = ..\..\Movies
SwtorRegKey = SOFTWARE\BioWare\Star Wars - The Old Republic

================================================== =====

Apart from doing this, I also read another tip somewhere about disabling the Windows 7 Aero theme (that is, if you're on windows 7). You won't have to permanently disable the aero theme, but you can set it in such a way that the theme will disable whenever you run SWTOR. To do this:

-right click on the shortcut to start swtor, then select properties
-click on the compatibility tab
-Under settings make sure "Disable visual themes" and "disable desktop composition" are checked

Applying these changes bumped up my fps by about 20. I hope this helps!
Kirsith
Juggernaut - Tank

Strange Allies