Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Horrid FPS

First BioWare Post First BioWare Post

Unscathed's Avatar


Unscathed
12.24.2011 , 02:27 PM | #1971
People need to stop getting confused with there internet speeds and fps.

You could have the worst connection going and have 110fps.

Adoan's Avatar


Adoan
12.24.2011 , 02:32 PM | #1972
Hey,

first off I want to thank everyone that spent time making this game. Thank you! This game is amazing and they have done an excellent job.

My problem is like so many others on this forum.

My computer specs:
I7 920 2.6 mhz processor
12 gigs memory
gtx 570 Over clocked
Vsync on 60 FPS mostly everywhere.
Randomly (in cities or small towns or sometimes entering combat) fps drop less then 5 for a split second then bounce back up to 59+.

Just wanted to report my experience as well for feedback.

I love the game and am going to play for along time.

Thank you,

Wurth Sith Assassin Level 33!
Dark Lord Adoan Sith Master

Daler's Avatar


Daler
12.24.2011 , 02:39 PM | #1973
q8200 OC to 2.66Ghz
RAM 6GB
GPU GeForce GTX560 OC ver. 900 GPU and 4270 mem

I have very low FPS in warzones, especially in Alderaan Civil War warzone.

with AMD 5850 low is 15 FPS
with GTX560 low is 15 FPS

Playing in 1920x1080 res with high settings, and vsync off.

When i have 15 FPS, of course i tryed to activate LOW settings, but is doesnt help, i have same FPS than on HIGH preset. Shadows on\off also doesnt matter.

Scenario for FPS falling:

1) Entering warzone, OK, I have 50+ FPS (as in solo or party, or any other place, outdoor or inside buildings)
2) In flying i have 30+ FPS
3) In pvp 20-30, and in "heavy" moments 15-20
4) I was killed, respawn on base and here i have 15-20 FPS


Also i prepeared feedback in visual style. My screenshots with comments on every stage of WZ.

link to report in google docs. click here.


About nvidia drivers, i used with same result:

285.62-desktop-win7-winvista-64bit-english-whql
and 290.53-desktop-win7-winvista-64bit-international-beta

ok my dxdiag here.

Spoiler

gnarkilli's Avatar


gnarkilli
12.24.2011 , 02:50 PM | #1974
Quote: Originally Posted by Ilyass View Post
Just unsubscribed...but i want to play!!!
FPS super-extra low everywhere in everymoment.
Tried all.
I found your problem.

Sony Vaio.


Ok its decent laptop, but the specs of laptops is misleading when it comes to gaming. The system RAM is shared with VRAM for a start, not to mention every compnoent is engineered to be as small as possible, with speed suffering as a result.


A rough rule of thumb would be a PC costing 500 (not inc monitor etc) would run this game perefctly, maxed out. Mine does, except for graphical artifacts that many are experincing, but no game breaker.


Now to achieve that same perfrmance in a LAPTOP form factor, you would be looking at dropping 2 or 3 THOUSAND. Maybe more really, skys the limit.

If you did not pay this much for your 'gaming laptop' then it is no such thing and you really shoudl just play games from 3 or 4 years ago.

Im not trying to be an idiot man. Its just true.

Sell the VAIO and get a desktop.


In fact ANYONE complaining of poor FPS while playing on a sub 2k laptop should be quiet now.

The specs simply do NOT scale with desktop PCs. Onboard video and shared RAM, means SLOW game performance. Sad fact of life Im afraid. I would say that a laptop of your spec is in reality less than half as fast as its desktop equivelent.


This should be a sticky on all gaming customer service Forums. 'LAPTOPS ARE NOT FOR GAMING (unless you custom built or spent mega mega bucks on it).

So come clean, what percentage of this thread complaining of low FPS are doing it on a device designed for miniaturisation and heat management over speed, with onboard video and shared system RAM?



God only knows how hot they must get xD
.

Chodenan's Avatar


Chodenan
12.24.2011 , 02:53 PM | #1975
Quote: Originally Posted by XIKeiyaZI View Post
This is on a single rig, my lower powered one to be exact. On any of the 3 PC's in my house, one which is running an AMD 550 BE on a 250, and the other with specs well beyond anything needed for modern day gaming, the game is running brilliantly.

Perhaps, again, it's either an issue with improper system setup, internet speeds, heat, or specific hardware incompatibility/bottlenecks.
This guy obv hasnt been reading all the posts of ppl having this problem.... Hey buddy there are dudes with leet *** setups that are having problems.... obv it isnt affecting everyone but a huge chunk of the community is..... so that being said keep ur snobby "MY COMPUTER IS JUST FINE MAYBE U GUYS NEED TO UPGRADE *trollface*" comments to yourself becuase you arent helping the issue in fact comments like these are gunna keep bioware from paying attention to this issue.

Eciso's Avatar


Eciso
12.24.2011 , 02:54 PM | #1976
Quote: Originally Posted by Daler View Post
q8200 OC to 2.66Ghz
RAM 6GB
GPU GeForce GTX560 OC ver. 900 GPU and 4270 mem

I have very low FPS in warzones, especially in Alderaan Civil War warzone.

with AMD 5850 low is 15 FPS
with GTX560 low is 15 FPS

Playing in 1920x1080 res with high settings, and vsync off.

When i have 15 FPS, of course i tryed to activate LOW settings, but is doesnt help, i have same FPS than on HIGH preset. Shadows on\off also doesnt matter.

Scenario for FPS falling:

1) Entering warzone, OK, I have 50+ FPS (as in solo or party, or any other place, outdoor or inside buildings)
2) In flying i have 30+ FPS
3) In pvp 20-30, and in "heavy" moments 15-20
4) I was killed, respawn on base and here i have 15-20 FPS


Also i prepeared feedback in visual style. My screenshots with comments on every stage of WZ.

link to report in google docs. click here.
Same here, just i get 5-7 less fps same even on low settings 800x600. BUT i dont have overclocked 560 videocard, i got 440. but i can run any other game on high setting without problem...........
Wanted:
Bounty Hunter, Commando
Got:
FPS issues, no fix, no dev response, unplayable crap

Zanguar's Avatar


Zanguar
12.24.2011 , 02:56 PM | #1977
i will say the same thing for the 10th time... same situation was on startup with WoW, Blizzard said it was roblem with their servers (hardware) and after changing servers all were smooth for every player, i think the same thing is here...
A: Screen shot or it didn't happen
B: No screen shot, it was a phone conversation...
A: ....screen shot or it didn't happen...

Chodenan's Avatar


Chodenan
12.24.2011 , 02:57 PM | #1978
Quote: Originally Posted by Habboi View Post
Hi all,

I've been researching this framerate problem for a while now and I have some things you can do that may help you improve your FPS but remember your hardware also needs to be good enough to run the game. However it is known that even powerful PC's are struggling with this game therefore it suggests an engine issue that I'm sure will be resolved. I also suspect Nvidia will release a driver that should increase performance for this game so that's something worth waiting for.

Regardless here are the list of things I have done:

1. The classic set to high settings and then to low settings.

2. Edited the games .ini which contains the graphic settings for your account. You can find this at: C:\Users\YOURUSERNAME\AppData\Local\SWTOR\swtor\settings

My ini is as follows:

Spoiler


Note that setting the TextureQuality = 0 is actually setting textures to medium / high so if you want even better FPS try 1 or 2. I believe Bioware are aware that high settings aren't working and thus we can only either have low or medium.

3. Right click on the SWTOR launcher and click properties. Select Compatibility and choose the following:

Disable Visual Themes
Disable Desktop Composition
Run as Administrator

4. Go to Control Panel and then Nvidia control panel. Choose Adjust image settings on the left and then slide the slider from quality to performance if it isn't already.

5. Make sure drivers are up to date and open up task manager and close any non essential programs like flash update, printer drivers etc. Really though you should have all this disabled on startup anyway. Want my advice? Use CCleaner to clean your firefox history and crap and also fix your registry, defrag using defraggler and do a disk check by right clicking on the C drive in my computer and using the tools tab. Reset and let it do its thing.

6. It has been suggested that playing in window mode also helps. While I was datacron hunting I was playing in a smaller resolution which obviously helped. In fact it helped a great deal so you should consider playing at a crappy resolution if visuals do not bother you like myself. Performance over visuals is my motto.

I still get a drop in framerates in certain places like the space station but its a "lot" better than it used to be. My hardware could be better though. Nvidia 285 GTX, Quad Core 2.66 ghz and 4gb ram windows 7 64 bit.

Oh yeah you should consider getting Windows 7 if you have Vista because there is such a huge difference in performance that it's crazy.

Hope that helps.
Hey i keep seeing posts about changing the .ini. but this folder path has nothing of the sort for me. i have no idea how to access this file.

Kirkkh's Avatar


Kirkkh
12.24.2011 , 03:00 PM | #1979
Quote: Originally Posted by gnarkilli View Post
I found your problem.

Sony Vaio.


Ok its decent laptop, but the specs of laptops is misleading when it comes to gaming. The system RAM is shared with VRAM for a start, not to mention every compnoent is engineered to be as small as possible, with speed suffering as a result.


A rough rule of thumb would be a PC costing 500 (not inc monitor etc) would run this game perefctly, maxed out. Mine does, except for graphical artifacts that many are experincing, but no game breaker.


Now to achieve that same perfrmance in a LAPTOP form factor, you would be looking at dropping 2 or 3 THOUSAND. Maybe more really, skys the limit.

If you did not pay this much for your 'gaming laptop' then it is no such thing and you really shoudl just play games from 3 or 4 years ago.

Im not trying to be an idiot man. Its just true.

Sell the VAIO and get a desktop.


In fact ANYONE complaining of poor FPS while playing on a sub 2k laptop should be quiet now.

The specs simply do NOT scale with desktop PCs. Onboard video and shared RAM, means SLOW game performance. Sad fact of life Im afraid. I would say that a laptop of your spec is in reality less than half as fast as its desktop equivelent.


This should be a sticky on all gaming customer service Forums. 'LAPTOPS ARE NOT FOR GAMING (unless you custom built or spent mega mega bucks on it).

So come clean, what percentage of this thread complaining of low FPS are doing it on a device designed for miniaturisation and heat management over speed, with onboard video and shared system RAM?



God only knows how hot they must get xD
Just no to all that.

Zanguar's Avatar


Zanguar
12.24.2011 , 03:00 PM | #1980
when i was changing things in *.ini the game is not launching at all...
A: Screen shot or it didn't happen
B: No screen shot, it was a phone conversation...
A: ....screen shot or it didn't happen...