Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Min specs not cutting it anymore since launch?

STAR WARS: The Old Republic > English > Customer Service
Min specs not cutting it anymore since launch?

Chiyeko's Avatar


Chiyeko
12.14.2011 , 02:06 PM | #1
Hello all,

I got in Yesterday witht he first wave and I was very happy however it cooled down quite rapidly. Where during the nov-25 beta weekend I could run smoothly with every on low or off, but with medium texture quality, now I only get max of 15 FPS (dropping to below 10 most of the time and going down to 2 even at times!) with everything on low or off.

I tried all I could, turning off programs in the background (which where running during the beta weekend!) making sure my settings where as low as it would go, but nothing helps.

The only conclusion I can draw is that the game has become more demanding gfx wise with the launch build. my CPU nor my Ram are taxed to the max (sadly can't see for the GPU) so doubt the issue rest there.

Now I know that I run on a 2 year old laptop, but as I said if this where my first time in game I would have just thought well this sucks guess I have to wait for January when I can get a new PC. But that is not the case as I played during beta.

So yes I am at a loss here, I really like to have more fun, but with such low FPS and FPS drops it just looses a lot of the fun factor. anything above 20 FPS and stable would make me more than happy!

List of things I tried/did:
*Drivers all up to date
*Background programs turned off as much as possible
*Settings on low/off
*Grass/trees of low
*Vsync off
*Security software in game mode (Bitdefender)
*restarted comp (you never know)

As I said anything that let's me run stable with 20 FPS or more would make me very happy.

Thanks in advance.
Inter arma enim silent leges.

Kotyy's Avatar


Kotyy
12.14.2011 , 02:11 PM | #2
MMOs and Laptops, Old ones defo, are really really really bad for gaming, game have some issues with performance so far but dont expect smooth gameplay on 2 years old laptop on decent graphics, just dont.

JoxerNL's Avatar


JoxerNL
12.14.2011 , 02:13 PM | #3
Post your DXdiag, it's the easiest way to have people help you.

Chiyeko's Avatar


Chiyeko
12.14.2011 , 02:13 PM | #4
Quote: Originally Posted by Kotyy View Post
MMOs and Laptops, Old ones defo, are really really really bad for gaming, game have some issues with performance so far but dont expect smooth gameplay on 2 years old laptop on decent graphics, just dont.
I just expect a smooth run on low low like I had in beta (though in beta I had med textures)

Beside:

WoW Never any issues
EVE sure 500 man fleet fight anyone? I am in
Skyrim, looking nice there buddy

So yeah shoot me and the damn laptop, but it has to last at least 1 more month sadly, after that it will be fried (yes I said fried not fired)
Inter arma enim silent leges.

Chiyeko's Avatar


Chiyeko
12.14.2011 , 02:16 PM | #5
DxDiag in spoiler, sorry should have posted that at once

Spoiler
Inter arma enim silent leges.

Frosten's Avatar


Frosten
12.14.2011 , 02:16 PM | #6
Quote: Originally Posted by Chiyeko View Post
Hello all,

I got in Yesterday witht he first wave and I was very happy however it cooled down quite rapidly. Where during the nov-25 beta weekend I could run smoothly with every on low or off, but with medium texture quality, now I only get max of 15 FPS (dropping to below 10 most of the time and going down to 2 even at times!) with everything on low or off.

I tried all I could, turning off programs in the background (which where running during the beta weekend!) making sure my settings where as low as it would go, but nothing helps.

The only conclusion I can draw is that the game has become more demanding gfx wise with the launch build. my CPU nor my Ram are taxed to the max (sadly can't see for the GPU) so doubt the issue rest there.

Now I know that I run on a 2 year old laptop, but as I said if this where my first time in game I would have just thought well this sucks guess I have to wait for January when I can get a new PC. But that is not the case as I played during beta.

So yes I am at a loss here, I really like to have more fun, but with such low FPS and FPS drops it just looses a lot of the fun factor. anything above 20 FPS and stable would make me more than happy!

List of things I tried/did:
*Drivers all up to date
*Background programs turned off as much as possible
*Settings on low/off
*Grass/trees of low
*Vsync off
*Security software in game mode (Bitdefender)
*restarted comp (you never know)

As I said anything that let's me run stable with 20 FPS or more would make me very happy.

Thanks in advance.
Turn Shadows off. Not low, but off. Thats what did it for me.

Chiyeko's Avatar


Chiyeko
12.14.2011 , 02:22 PM | #7
Quote: Originally Posted by Frosten View Post
Turn Shadows off. Not low, but off. Thats what did it for me.
Those are off already, one of the first things I do in general seeing they eat performance and never really ad much for me.
Inter arma enim silent leges.

Larishet's Avatar


Larishet
12.14.2011 , 02:24 PM | #8
Quote: Originally Posted by Chiyeko View Post
Hello all,

I got in Yesterday witht he first wave and I was very happy however it cooled down quite rapidly. Where during the nov-25 beta weekend I could run smoothly with every on low or off, but with medium texture quality, now I only get max of 15 FPS (dropping to below 10 most of the time and going down to 2 even at times!) with everything on low or off.

I tried all I could, turning off programs in the background (which where running during the beta weekend!) making sure my settings where as low as it would go, but nothing helps.

The only conclusion I can draw is that the game has become more demanding gfx wise with the launch build. my CPU nor my Ram are taxed to the max (sadly can't see for the GPU) so doubt the issue rest there.

Now I know that I run on a 2 year old laptop, but as I said if this where my first time in game I would have just thought well this sucks guess I have to wait for January when I can get a new PC. But that is not the case as I played during beta.

So yes I am at a loss here, I really like to have more fun, but with such low FPS and FPS drops it just looses a lot of the fun factor. anything above 20 FPS and stable would make me more than happy!

List of things I tried/did:
*Drivers all up to date
*Background programs turned off as much as possible
*Settings on low/off
*Grass/trees of low
*Vsync off
*Security software in game mode (Bitdefender)
*restarted comp (you never know)

As I said anything that let's me run stable with 20 FPS or more would make me very happy.

Thanks in advance.

Might as well just give away your account. Can I have your stuff?

Chiyeko's Avatar


Chiyeko
12.14.2011 , 02:26 PM | #9
Quote: Originally Posted by Larishet View Post
Might as well just give away your account. Can I have your stuff?
Hell no!

*Calls in an orbital bombardment*
Inter arma enim silent leges.