Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

GeForce 470, 12 GB RAM, 4 core CPU and this game is unplayable

STAR WARS: The Old Republic > English > Customer Service
GeForce 470, 12 GB RAM, 4 core CPU and this game is unplayable

Swampfot's Avatar


Swampfot
01.19.2012 , 07:13 AM | #11
Quote: Originally Posted by MietekFog View Post
So not even one answer from Customer Service want i paid for?
Customer Service can't answer you right now... they are busy playing WoW.

AntiyouXx's Avatar


AntiyouXx
01.19.2012 , 07:13 AM | #12
My system specs aren't quite as nice as yours but my game is still running smooth as always, shadows and AA both on low though.
That was intense. Really intense. Well not really intense, but pretty intense.

Chaineddestiny's Avatar


Chaineddestiny
01.19.2012 , 07:27 AM | #13
im running a system not quite as good as yours, and i play the game on high with everything (except shadows) maxed out. stable 60 fps with minor drops here and there.

3.0 ghz intel core duo
6gb ddr3 ram
gtx 560 ti
vista 64bit

Dalal's Avatar


Dalal
01.19.2012 , 07:51 AM | #14
http://www.swtor.com/community/showt...198142&page=11

This is a known issue. This thread has been going on since the game launched, and although the Devs haven't handled the situation like they should be, they have at least addressed it.

I personally have only been getting bad frame rate in warzones. However, after this patch I've noticed a significant improvement in them. I found a possible fix for some users in the link below.

http://www.swtor.com/community/showt...192790&page=12
i5 2500k @ 4.6GHz - Nvidia Geforce 670 GTX 2GB - 8GB DDR3 1600MHz
Corsair Force 3 90GB SSD - Windows 8 Pro (64-Bit)