Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher freezing.

Pandabeer's Avatar


Pandabeer
12.14.2011 , 01:13 PM | #1
Hello,

Im trying to update my launcher to play the pre-game thing, but my launcher keeps freezing up when im trying to update..
I tried everything in this thread: http://www.swtor.com/community/showthread.php?t=272

Specs;
Intel i5 2500k
8GB DDR3 RAM
MSI R6850
Windows 7 64bit

How can I fix this problem?

Fooolking's Avatar


Fooolking
12.14.2011 , 01:18 PM | #2
Hey Pandabeer!

Can I ask a few questions?

What does your launcher look like when you open it? Do you see a sanguine cityscape in the background of the launcher?

What happens when you open your launcher? Does it grey out and claim to be looking for a 'launcher update'?

Lastly. If you check your main ToR directory. C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic do you have a file named FixLauncher.exe?

My friend had a launcher problem and we bashed our heads against it for a while.

The problem was a bad Launcher.exe file. We fixed it by deleting Launcher.exe (Be sure to back it up if you try this...) and running FixLauncher.exe. He didn't have FixLauncher.exe in his SwTOR directory, so I had to zip it and send it to him.

Afterwards his launcher functioned and he was able to patch the game.

Pandabeer's Avatar


Pandabeer
12.14.2011 , 01:22 PM | #3
Yes, i did launch fixlauncher.exe (which was in the thread aswell)


http://www.pandabeer1337.nl/upload/1323890477040.png

^ My launcher, it freezes when 4GB left (i downloaded the 8GB for 5 times now :P)

Fooolking's Avatar


Fooolking
12.14.2011 , 01:23 PM | #4
Unfortunately that's a different issue...~_~

Sorry. I really don't know what's going wrong there...

Pandabeer's Avatar


Pandabeer
12.14.2011 , 02:20 PM | #5
I tried running it in compatibility mode on windows xp, yet no luck.