Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Getting Keepass 2.x to work with the launcher

STAR WARS: The Old Republic > English > General Discussion
Getting Keepass 2.x to work with the launcher

Noktar's Avatar


Noktar
01.18.2012 , 03:00 PM | #1
Figured this might help those of us who use keepass(Website) for our passwords. It turns out Keepass doesn't like the little "trademark" signs used by the Launcher window, but keepass supports wildcard for window recognition. After these steps using the global auto-type should work (it does for me)

1. Open the keepass entry for Star Wars: The Old Republic
2. Click the Auto-type tab
3. Click the Add button to add a custom sequence for a specific window.
4. In Target Window enter //^STAR WARS.: The Old Republic.$//
5. Select Use custom keystroke sequence

If you don't use a security key:
6. Enter {Password}{ENTER} as the custom sequence (the launcher saves the username, so we don't enter it)

If you DO use a security key... I don't have one, but I figure this would work and put you in the security key textbox:
6. Enter {Password}{TAB} as the custom sequence (the launcher saves the username, so we don't enter it)

7. Click OK
8. (Optional) Check Two-channel auto-type obfuscation (added security from keyloggers/clipboard spies). It seems to work OK.
9. Click OK
10. Save your changes

You might want to repeat step 1-4 for the website login. in that case the Target Window will be Star Wars: The Old Republic | Login* ; Keep the default sequence, but you might have to alter it if you use a security key.

Pookylicious's Avatar


Pookylicious
02.01.2012 , 04:31 PM | #2
Hey,

tried this serveral times but doesnt work wheres is my fault the window sequence really correct for the actual patch?

Moericus's Avatar


Moericus
02.11.2012 , 03:42 PM | #3
Wasn't working for me either, despite playing with the regex a bit more--went so far as to dig into the source code in debug. Finally, it dawns: SWTOR's launcher elevates to an Administrator process when it starts, automatically. KeePass doesn't. Technically, I can't figure out how to debug this scenario to prove it in source, but... if I run KeePass as Administrator (this is both a single-use context menu option and a shortcut-based setting in the compatiblity tab), it works for the swtor launcher.