Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Cannot install from SWTOR_setup

STAR WARS: The Old Republic > English > Customer Service
Cannot install from SWTOR_setup

Packetdancer's Avatar


Packetdancer
12.14.2011 , 02:18 PM | #11
Quote: Originally Posted by adam_lord View Post
I just want some one to tell me that it will be fine and will work from me copying it over from one computer to another and just make my own shortcut's
You should be fine. You might need to add the game to the Windows Firewall manually, and the Uninstall option won't work right without going through the installer, but those aren't insurmountable.

Quote:
p.s i got avatar =)
Huzzah!
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

adam_lord's Avatar


adam_lord
12.14.2011 , 02:27 PM | #12
Yer they are not too bad. I have added it to my firewall and it is downloading. i am randomly getting my launcher crash when it is downloading though. it is just a window's program has stopped working. in the event log i get this:

Faulting application name: launcher.exe_SWTOR Launcher, version: 3.1.7.0, time stamp: 0x4ec55d62
Faulting module name: msvcrt.dll, version: 7.0.7600.16385, time stamp: 0x4a5bda6f
Exception code: 0xc0000005
Fault offset: 0x0000a05b
Faulting process id: 0x364
Faulting application start time: 0x01ccba9bec25ae38
Faulting application path: C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\launcher.exe
Faulting module path: C:\Windows\syswow64\msvcrt.dll
Report Id: fa2ba917-2690-11e1-af31-20cf30435bbe

Any idea's what that may be. Sorry to be a pain with all this but thanks' for helping me out

Gvaz's Avatar


Gvaz
12.14.2011 , 02:40 PM | #13
You have to go into the rar file that is like 14mb or w/e size and extract that somewhere (like to your desktop or whatever) and then run the launcher inside that

Just running it from the downloaded exe never works for me

Packetdancer's Avatar


Packetdancer
12.14.2011 , 03:04 PM | #14
Quote: Originally Posted by adam_lord View Post
Any idea's what that may be. Sorry to be a pain with all this but thanks' for helping me out
Okay, I take that back. If you skip the installation, it's possible to end up with an outdated copy of that runtime. The quickest fix for this is to go grab the latest copy from Microsoft in a handy VS2008 runtime redistributable package. Once you're up-to-date, hopefully you won't have that crash.
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

knoblejames's Avatar


knoblejames
12.14.2011 , 04:40 PM | #15
I have same problem install of client not working and nothing on this post is helping . It just zips and disappears

SHRenauk's Avatar


SHRenauk
12.14.2011 , 05:00 PM | #16
See i was having similar issues in the beginning of this post, but the other laptop that the client worked on was a windows 7 home premium just like this one, both laptops fit within the specs of the game, but when the download goes to extract the software for the client it just shut down. any suggestions?

knoblejames's Avatar


knoblejames
12.14.2011 , 07:50 PM | #17
I tried contacting EA customer service through "live chat" and they seemed to blame it on Origins server being down...so did everyone who has this buy it from Origin or are they just guessing because they seemed like they were speculating

adam_lord's Avatar


adam_lord
12.15.2011 , 12:14 PM | #18
From what I can see of the problem it would not be Origins that is coursing this as the installer does not come from Origins and also does not use or refer to Origins at all in the install process.

from what I posted in the first page of the crash report from the dump file you can see it is some thing to do with the langue selection process the installer is trying to run. when you load the installer it ask's what language you want to pick. it is this that is failing. not sure why but if it fail's then the install just stop's.

I would try and talk to EA about this but when I have in the past it will go on for hours with them asking you to do thing's you have done and in the end they will not fix the issue because they cannot.

The only people that are likely to fix the issue are the people that right the code for the isntall.exe so if that part fail's it fall's back to another section of the code so the install can carry on.

on a said note I would like to thank Packetdancer for all his help. i would suggest if anyone is having issue's to check his guild first and then try to contact EA. but I don't think they will listen to you.

If I do find a fix or fix it my self at any point I will try and update this post.

Sgt-Monkman's Avatar


Sgt-Monkman
12.15.2011 , 12:55 PM | #19
I had the very same issue...would not install from the *.exe

So I have quit FRAPS and guess what...it's not installing.

Thanks for the workaround on that one.

Rgds

Max

adam_lord's Avatar


adam_lord
12.15.2011 , 02:02 PM | #20
I have played with my computer some more and now got it working.

it turn's out it was a window's update some where. I had not updated window's since the 31/4/2011. there must be a patch some where in the 40 I installed that has fixed the issue.

if any one else is still having this issue with Window's 7 Home Premium I suggest you do this.

Also a friend advise me to try booting into safe mode with network enabled to see if it fixed the issue. it did not for me but it show's that nothing else was conflicting with it from the software I was running. you may also want to try this.

Thanks for every one's help. hope you all get it fixed to and see you in game