Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

not showing servers

bigmikec's Avatar


bigmikec
12.14.2011 , 10:34 AM | #1
when i get into the game to server select screen its not showing any servrs so that i can pick one please help as i did not wait all this time and pay 150$ for nothing!

GamewizX's Avatar


GamewizX
12.14.2011 , 10:36 AM | #2
Do you have the server select button on the bottom left? What is your screen showing right now? You'll need to provide a little more info.
The Shadowlands -Ξ▒▓██ The Gamewiz Legacy ██▓▒Ξ- The Shadowlands
www.oldrepublicdads.com | Proud member of -=ORD=- | www.oldrepublicdads.com
Aaliyah - 50 Sage (TK) | Corthin - 50 Sentinel (CB) | Hartman - 35 Commando (GN)

bigmikec's Avatar


bigmikec
12.14.2011 , 10:42 AM | #3
it says server select at the top at the bottom left it says quit credits prefences and bottom right it says next but it is not in any way shape or form letting me pick a server at the bottom middle i can switch between europe and america and ive done that and it still does not show any servers! ive even tried restarting my comp!

GamewizX's Avatar


GamewizX
12.14.2011 , 10:44 AM | #4
Show you are showing the windows for selecting the servers but there are no servers listed? I would suggest contacting customer support on the issue.

http://www.swtor.com/community/forumdisplay.php?f=11

http://www.swtor.com/support
The Shadowlands -Ξ▒▓██ The Gamewiz Legacy ██▓▒Ξ- The Shadowlands
www.oldrepublicdads.com | Proud member of -=ORD=- | www.oldrepublicdads.com
Aaliyah - 50 Sage (TK) | Corthin - 50 Sentinel (CB) | Hartman - 35 Commando (GN)

bigmikec's Avatar


bigmikec
12.14.2011 , 10:45 AM | #5
yes that is correct

iain_b's Avatar


iain_b
12.14.2011 , 10:50 AM | #6
Quote: Originally Posted by bigmikec View Post
i did not wait all this time and pay 150$ for nothing!
My Little Pwny
Kulok Dunar, Powertech and GM of MLP. Want to join? Click here for info.

Squadron 1020 & 367

Methosan's Avatar


Methosan
12.14.2011 , 10:51 AM | #7
others have a similar problem. SWTOR just tweeted a response to go to customer support forums:

http://bit.ly/tcw1UG - from their tweet