Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Swtor Launcher Won't Open

First BioWare Post First BioWare Post

Masscaliber's Avatar


Masscaliber
01.14.2012 , 03:34 PM | #1
I've been playing swtor for wuite some time now and it has always worked. Today for no reason whatsoever when I tried to log in at the launcher It said something like "No Server Connection" or "Server Error" then I closed it and tried to re open the launcher and it didn't work at all. I look in my task manager and it was running in the manager but it wouldn't open. I tried restarting my computer but that didn't work either. PLEASE HELP ME!
"Do it! Strike him down with all your anger and your hatred, and your journey to the dark side shall be complete!"-Darth Sideous(AKA Emperor Palpatine)
http://www.swtor.com/guilds/203318/warriors-science

Seffrid's Avatar


Seffrid
01.14.2012 , 03:36 PM | #2
Try running the Fix Launcher exe file in the game folder, and if that doesn't work make sure there isn't a problem with your ISP - check their forums to see if anyone else is having the same problem as it could simply be a routing problem to the game's servers.

Ratae's Avatar


Ratae
01.14.2012 , 03:38 PM | #3 This is the last staff post in this thread.  

Hello Masscaliber,

Please try the following troubleshooting steps to try to resolve the problem:
Ensure that you have the correct ports opened in your router settings. See this link:
http://www.swtor.com/support/helpcenter/2015 and that you have both the launcher.exe and the swtor_setup.exe added to the exceptions of your firewall and any antivirus software.

Check also the Launcher Troubleshooting Guide:
http://www.swtor.com/community/showthread.php?t=272

Finally could you check that the date and time are set correctly on both your Windows clock settings and BIOS clock.

Please let us know if this helps resolve your issue.
Ratae | BioWare Customer Service - Forum Support

Masscaliber's Avatar


Masscaliber
01.22.2012 , 06:41 PM | #4
Quote: Originally Posted by Seffrid View Post
Try running the Fix Launcher exe file in the game folder, and if that doesn't work make sure there isn't a problem with your ISP - check their forums to see if anyone else is having the same problem as it could simply be a routing problem to the game's servers.
Thanks that solved it.
"Do it! Strike him down with all your anger and your hatred, and your journey to the dark side shall be complete!"-Darth Sideous(AKA Emperor Palpatine)
http://www.swtor.com/guilds/203318/warriors-science

MyNinjaPenguin's Avatar


MyNinjaPenguin
01.24.2012 , 05:30 PM | #5
So, I'm having almost the same problem. My launcher won't open, but when I open Task Manager I can see it running. I tried running FixLauncher to no effect. Any suggestions, anyone?

Juggasaurusrex's Avatar


Juggasaurusrex
02.26.2012 , 11:11 PM | #6
Delete the "patch" folder. Remove it completely from your system. Use the launcher.exe again and it will recreate and update your patch folder. It should run now no problem

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic\patch

Your folder might be EA instead of Electronic Arts.
Do unto others as you would have them do unto you.