Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Complete Lag

First BioWare Post First BioWare Post

DarthNofu's Avatar

12.14.2011 , 09:49 AM | #1
I just got into the game and have a problem with big areas. My computer seems to lag heavily with no signs of stopping when I am in a big area but in smaller areas it seems fine. I have all settings on low. Help?

Ahkronn's Avatar

12.14.2011 , 09:50 AM | #2
Have your tried to turn off Shadows?

Tozie's Avatar

12.14.2011 , 09:50 AM | #3
Buy a new computer, problem fixed!

SkyNett's Avatar

12.14.2011 , 09:51 AM | #4
What are your specs?

Conveeyor's Avatar

12.14.2011 , 09:51 AM | #5 This is the last staff post in this thread.  
You may find some helpful information here:

Conveeyor | BioWare Customer Service - Forum Support