Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

A "My account" pre play problem

STAR WARS: The Old Republic > English > Customer Service
A "My account" pre play problem

Radtaco's Avatar


Radtaco
12.14.2011 , 09:19 AM | #1
Hi, i live in Australia and I pre ordered a standard edition from amazon.com on the 30th of November, and redeemed my code the same day.
Now, after the resent forum update, it says on the tick boxes that I have not redeemed a code and I need to to play pre play. But when I click on the redeemed codes (sorry for lack if proper name) it says I have a standard pre order edition. I am very confused and I would appreciate any help. Thanks

ColdLogic's Avatar


ColdLogic
12.14.2011 , 09:20 AM | #2
Same with me, I'm in America. I need this fixed. On the account page it says I'm not ready and haven't entered a code.

But when I go to code redemption it says I already put in the code for m digital delux on 08.24.2011....
Feet First Into Hell (FFIH):Guild Leader
◘ (PvP) Est. Hardcore/Light RP:
••••Official Website Feet First Into Hell••••

Radtaco's Avatar


Radtaco
12.14.2011 , 10:47 PM | #3
Bump need answers

Rulyen's Avatar


Rulyen
12.14.2011 , 10:50 PM | #4
When you go to 'My Account', then to 'Code Redemption' and scroll down to 'Code History' you should see your already registered pre-order.

The product key will be sent to you by Origin about 16th December.

You also would like to have a look here:

http://www.swtor.com/community/showp...&postcount=499

Thank you.

Bump, answers provided.
. Fear teh Beta Pixel!

Radtaco's Avatar


Radtaco
12.14.2011 , 10:52 PM | #5
oh, Thank you, i completely miss read what it said