Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

fps problems (please assist)

STAR WARS: The Old Republic > English > Customer Service
fps problems (please assist)

Escaflownae's Avatar


Escaflownae
01.10.2012 , 08:41 AM | #1
I'm having fps issue any assistance would be great.

Here is my system build

T1100 x6 core AMD processor
Crossfire HD 5770 Radeon Cards
Asus M4A88T-V Evo Motherboard
8gigs 1600 Kingston ram
750 watt power supply
120g SSD V-Pro Kingston
3 - 500g data drives


Game Settings

High
No Shadows
No Bloom


My Issue

I can play any game on the market at 100fps minimal yet when I load into swtor I'll be at 100 fps in my ship and get fps drops of 70-80 at random points. I'll be in the republic fleet and only be hitting 30-40 fps when I'm sure I should be getting more.

My main issue is I never notice any micro stuttering in other games but in here I get what I can only call micro stuttering or small fast lag spikes. It makes the game appear to me choppy.

*Note* If I'm running by myself out in the open zones I'm playing fine with small micro stutters but I'm still at 80-100 fps at all times.

Things I've tried

Windows XP SP3 Compatibility mode
Turning all textures to medium
Reducing all graphics to extreme low ( this helps alot but come on I'm hitting 200-250 fps in this mode and I should be able to play at higher levels.)
Updated my drivers to the newest out there (not beta drivers)
Courage is not the absence of fear, but the strength to do what is right in the face of it.

Escaflownae's Avatar


Escaflownae
01.10.2012 , 12:09 PM | #2
So is anyone having problems with the crossfire as well with a similar setup?
Courage is not the absence of fear, but the strength to do what is right in the face of it.

Miffy's Avatar


Miffy
01.10.2012 , 12:10 PM | #3
I can't get crossfire to work.

Jujjan's Avatar


Jujjan
01.10.2012 , 12:11 PM | #4
Seems like you are only getting juice as if using just one of the cards
I work for
Behave or i will collect your bounty

SWG < Chimaera EU > BH--> Kotz Sark

Escaflownae's Avatar


Escaflownae
01.10.2012 , 03:14 PM | #5
Yea thats what it feels like yet everything shows two cards are running and my crossfire is enabled in the AMD tools. I have no other idea on how to test it or verify that it's working.

Any suggestions on testing the crossfire or enabling crossfire in swtor?
Courage is not the absence of fear, but the strength to do what is right in the face of it.

Escaflownae's Avatar


Escaflownae
01.11.2012 , 08:07 AM | #6
OK so an update.

I actually went into my video card control console (CCC) and disabled Catalyst A.I. That seemed to make everything smooth and almost completely take out my micro stuttering.

I the turned everything up to full and turned shadows on and now my shadows won't stop flickering non-stop. So I turned them down to low and they stopped flickering.

My problem is that I'm now getting 14-30 fps in the Republic Fleet when I was getting more than that a while back before all the changes but it was choppy before the changes with high fps and now it's choppy with low fps.

Should I just bite the bullet and upgrade my crossfire 5770's to a higher end card. If so what card should I go with? A geforce 560 TI or a Radeon 6950/6970?
Courage is not the absence of fear, but the strength to do what is right in the face of it.

Escaflownae's Avatar


Escaflownae
01.11.2012 , 10:39 AM | #7
Anyone want to comment?
Courage is not the absence of fear, but the strength to do what is right in the face of it.

Escaflownae's Avatar


Escaflownae
01.11.2012 , 03:00 PM | #8
bump^
Courage is not the absence of fear, but the strength to do what is right in the face of it.

Jabatheruss's Avatar


Jabatheruss
01.11.2012 , 03:02 PM | #9
Quote: Originally Posted by Escaflownae View Post
Anyone want to comment?
You mean you expect support on a customer support forum? Obviously you are new here.
I have as much authority as the Pope. I just donít have as many people who believe it.

Escaflownae's Avatar


Escaflownae
01.11.2012 , 03:43 PM | #10
Look I know I don't have a low end pc as James has stated. My pc is just fine there has got to be something some kind of a setting that isn't right that I need to look at. I mean why can my specs blow games like bf3 up to 150fps other games to 180+ and this one with medium textures and no shadows and no bloom bring my performance to a crashing 12-30fps?

I'm not going to threaten to quit that is just silly. However I would like discussion on this topic. If someone there see that I might need to change something let me know I'm looking at everything now and nothing is standing out at me.
Courage is not the absence of fear, but the strength to do what is right in the face of it.