Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

stuck in start up loading screen

 

jeffll's Avatar


jeffll
01.09.2012 , 04:13 PM | #1
my game is stuck in the star wars the old republic loading screen. i have closed it two times and tried again. but all its doing is making the ship noises and the loading icon is still working. but ive been waiting for a very long time. so can i have some help. and also it worked alot before this.

Ice_mak's Avatar


Ice_mak
01.09.2012 , 04:16 PM | #2
Try this, and reply back:

(1) Close it all down
(2) Start up the launcher
(3) Log into the launcher
(4) wait for the software download version check status bar thing at the bottom
(5) DO not click Play, instead click that gears icon on the bottom left
(6) click repair and see if that works (might take 5-20 minutes)

That worked for me, after I updated my sound driver to the latest version, but might be unrelated.

Ice_mak's Avatar


Ice_mak
01.09.2012 , 04:17 PM | #3
also, run DxDiag.exe say yes and Save results, open the result and copy and paste them here as a Spoiler (remove computer name) incase anyone from support actually reads this and wants to help.

jeffll's Avatar


jeffll
01.09.2012 , 04:30 PM | #4
didnt work

jeffll's Avatar


jeffll
01.09.2012 , 04:36 PM | #5
Help!!!!!!!!!!!!

CerberusZA's Avatar


CerberusZA
01.11.2012 , 11:56 AM | #6
I am having exactly the same issue on my side. Launch the game and just before you get to your Server List there is a loading screen and it stays there and loads forever, never resolving. This only started happening to me last night. I have done the whole repair/redownload/drivers etc and nothing happens but I have a theory. Last night before I logged off I just got my Legacy name. This is the name that normally carried over to your other characters,but I already had a level 24 bounty hunter so here is my theory, when I got my legacy name it added to my sith warrior but for some reason my inactive character the bounty hunter isn't updated or what ever the case and now the server isn't sure what to display for me. Yes I know this is just speculation but it seems a little to coincidental. Also I have a brother on the EXACT same line that played with me and he gets in fine the only difference is that he doesn't have a 2nd character only 1.

I hope Bioware looks into this soon I was enjoying my game so much but now I can't even get to my character in NULL SPACE!

Annoying.

Regards
CerberusZA

LargeCheddar's Avatar


LargeCheddar
01.11.2012 , 12:09 PM | #7
Quote: Originally Posted by jeffll View Post
my game is stuck in the star wars the old republic loading screen. i have closed it two times and tried again. but all its doing is making the ship noises and the loading icon is still working. but ive been waiting for a very long time. so can i have some help. and also it worked alot before this.
You're not alone - this issue was brought up half a month ago and is affecting a lot of players. I have the same problem.

BioWare however in their infinite wisdom have done nothing to fix this problem.

RangerNRK's Avatar


RangerNRK
01.11.2012 , 08:48 PM | #8
As stated above this is a problem. i just recently downloaded the game and had everything set up only to play the game for several minutes and get kicked off; after trying to re-log in i get stuck at the load screen (pic on the game box) with the little loading gear in the bottom right only to have it stop and play music which stops after several minutes leaving me with a load screen and having to task manager shut down the program. BIOWARE HELP US!!!!!!!

IF I CANT EVEN PLAY MY GAME BECAUSE OF THIS THEN I WANT TO BE REFUNDED; I DIDNT PAY ALL THIS JUST FOR A LOAD SCREEN AND A MINUTE AND A HALF OF SOUNDTRACK MUSIC

xxnoctisx's Avatar


xxnoctisx
01.11.2012 , 08:52 PM | #9
yeah..im having this issue too and its gotten worse to where it wont even start the launcher, when i click on the shortcut and the launcher comes up, i try to log in but it says the launcher is unavailable see the forums for more info. this all started off with the infinite load screen so i tried to reinstall it and now i have this problem..