Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Horrid FPS


saberbear's Avatar


saberbear
01.09.2012 , 05:43 PM | #501
I looked at alot of posts now and alot people including myself are getting bad fps coz of the processor even though they are higher than what bioware has said is needed.
I like to pvp but atm i can't do it with 5 -15 fps.

Trojan_Rabbit's Avatar


Trojan_Rabbit
01.09.2012 , 05:44 PM | #502
Quote: Originally Posted by Epiphone View Post
Quick question! Could this processor handle TOR?
Yes. SWTOR is not multithreaded, so that processor would probably do better than my i7 which has a frequency a little lower than that one.

jediknightmiles's Avatar


jediknightmiles
01.09.2012 , 05:45 PM | #503
I mostly lag in buildings/ships and sometimes very bad outside. I have everything low shadows off etc still laggy.
ị████████████████████████████████ị╠≡ị⊑°⊒ị▀▀▀▀ị█ị GayPride

trooperrob's Avatar


trooperrob
01.09.2012 , 05:46 PM | #504
Quote: Originally Posted by Fellthar View Post
Umm... you didn't read my post did you? That was my conclusion too.
I dont have the time to read every word on every post but yes you are right.

Silarr's Avatar


Silarr
01.09.2012 , 06:08 PM | #505
I managed to run the game around 60-70fps benchmark avg on Tatooine on a amd athlon II x4 640 and a hd 4870 (11.12) on high without bloom and shadows. When the game runs well my gpu's fan works quite high, which practically means high utilization.

What happens though is after some time or some alt+tabs, the gpu/cpu utilization goes down, fan goes silent. For some reason the game stops utilizing my hardware the same way it did. At this time my benchmark avg goes down to 30-40fps and it stays there till I restart the client. Same thing happens in PvP and ofc my fps goes down to 15..

It's obviously an optimization issue on their side, but it could be also due to drivers.. Though Amd doesn't seem to bother with Swtor much on their 12.1 drivers. My performance went down with the 12.1, even more with the 12.1a.
Wooooooooow.........
I am too one of the 5%

Xasom's Avatar


Xasom
01.09.2012 , 06:10 PM | #506
Hmm, according to tom's hardware, Swtor scales with multi-cores. Here is the link:

http://www.tomshardware.com/reviews/...ew,3087-8.html

Looks like it doesn't really matter that much, if you have a i3 dual core, cause @3 Ghz it's almost as good as an AMD or Intel quad core. AMD CPUs on the other hand perform really bad, if it's a dual core.

So in the end overclocking a dual core intel cpu, which is below 3 Ghz, you have a chance to boost your fps as good as getting a quad. If it was an amd dual core, I would say buy a better processor.

Killoran's Avatar


Killoran
01.09.2012 , 06:23 PM | #507
changing of graphics has no impact at all, my fps is usaly between 10-20fps but goes alot less sometimes.

Graphic card used : Geforce GTX 560 Ti
Driver version: 285.62 (also used 290.53 but doesnt help)
Use of a CrossFire system: No
Drop of FPS in the confined spaces (buildings/ships): Yes
Server name: every server ive been on..

had a ATI radeon HD 5750 before and had the same problems then also

reformated my pc, installed windows drivers and star wars and i still have 10-20fps

other pc info

cpu: 3.2ghz i5
ram:8gb ddr3
motherboard: biostar TH55B HD



Just thought id add it in, every little helps maybe. but its making the game realy unplayable.

Siokai's Avatar


Siokai
01.09.2012 , 06:38 PM | #508
UPDATE

I had an AMD Phenom II x 4 @ 3.2 , 12 GB Ram, and Radeon 6850.


I had horrible lag in Warzones 5-15, and about 100 on my ship, and relatively high 50+ everywhere else.

Well I decided to dish out and upgrade my motherboard and CPU. I now have an i5 2500k with 8GB Ram and I get no lag, anywhere, whatsoever, at all, zomgz i love it.

Dunno what it was really, but that's my update. =/

trooperrob's Avatar


trooperrob
01.09.2012 , 06:39 PM | #509
Quote: Originally Posted by Siokai View Post
UPDATE

I had an AMD Phenom II x 4 @ 3.2 , 12 GB Ram, and Radeon 6850.


I had horrible lag in Warzones 5-15, and about 100 on my ship, and relatively high 50+ everywhere else.

Well I decided to dish out and upgrade my motherboard and CPU. I now have an i5 2500k and I get no lag, anywhere, whatsoever, at all, zomgz i love it.

Dunno what it was really, but that's my update. =/
its because you got rid of the processor bottleneck allowing your video card to run at full bore

MajorMelchett's Avatar


MajorMelchett
01.09.2012 , 06:41 PM | #510
Quote: Originally Posted by Xasom View Post
Hmm, according to tom's hardware, Swtor scales with multi-cores. Here is the link:

http://www.tomshardware.com/reviews/...ew,3087-8.html
From the artical.
Quote:
Our testing shows that the lowest frame rates in this game are usually outdoors, especially when foliage is involved. We’ve found the Twi’lek village on Typhon to be a good representation of a demanding area, so we made our benchmarking passes at this location using Fraps.
They benched on typhon which IMO is frankly one of the worst areas to do the bench (how they could consider this a demanding area is beyond me), they should have used republic fleet or courosant.

Frankly for me, the bench area renders the artical invalid.