Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Howto: rid off windows key, alt+tab and \ key

STAR WARS: The Old Republic > English > STAR WARS Discussion
Howto: rid off windows key, alt+tab and \ key

Fate-'s Avatar


Fate-
01.06.2012 , 06:42 PM | #1
When playing SWTOR i got pissed off with 3 things that kept happening while in combat..

1) Pressing the \ key would open "Open Ticket" window.
2) Pressing the Left Windows Key would switch to Windows.
3) Pressing ALT+TAB would also switch to Windows.

After looking and testing several solutions i found a working solution via a program called SharpKeys, where i mapped:
"\" into F10
"Left Windows Key" into F11
"ALT" into F12 (so pressing ALT+TAB would not switch back to windows anymore, it will send F12+TAB, so most likely ALT+TAB will behave as simple TAB, since F12 for example is not being used.

You can of course remap the 3 keys into something else, i just tried F10, F11 and F12 for sake of testing, i may change them.


Anyway, just tested ingame and its working.

Im running Windows 7 64bits.

You can download program from:
http://sharpkeys.codeplex.com/


I'm sure many of you will enjoy this tip of mine


~ Fate ~



EDIT:
Ok just decided and im sharing my final key remap using SharpKeys:
"\" --> Function: F11
Special: Left Alt --> Special: Right Shift
Special: Left Windows --> Special: Right Ctrl

Like this we able to use both "Windows Left Key" and "Left Alt" key as modifiers
"May the force be with you.. always"

Stjarnan's Avatar


Stjarnan
01.06.2012 , 06:55 PM | #2
I really appreciate this. Thank you.

Some people would just settle when they find the solution, instead you made the decision to share it with all other people with this problem, i bow for you.

Fate-'s Avatar


Fate-
01.06.2012 , 07:20 PM | #3
Quote: Originally Posted by Stjarnan View Post
I really appreciate this. Thank you.

Some people would just settle when they find the solution, instead you made the decision to share it with all other people with this problem, i bow for you.



Check my EDIT in my initial post, wher basically i remap keys into other modifiers keys so we can use both ingame


1) Also: I suggest enabling ingame all 3 extended bars:
ESC -> Preferences -> Game -> User Interface -> Quick Slots * and enable "Enable Left Quickslot", "Enable Right Quickslot" and "Enable Bottom Center Quickslot".
https://public.sn2.livefilestore.com...ars.jpg?psid=1


2) Secondly: to bind keys to each slot you go to:
ESC -> Preferences -> Key Bindings -> Quick Slot * and now just set the keys to all slots in left, bottom, and right bars
https://public.sn2.livefilestore.com...ngs.jpg?psid=1


Cheers all ~
"May the force be with you.. always"