Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Workaround for excessive mouse sensitivity when moving

STAR WARS: The Old Republic > English > New Player Help
Workaround for excessive mouse sensitivity when moving

Langkard's Avatar

12.14.2011 , 02:11 AM | #1
Many of us who have played other games find the movement far too sensitive when turning and moving using the mouse (either with the keyboard + right mouse button or left button + right button together). Here is a simple workaround that will help, without having to go outside the game and mess with your mouse software itself.

In preferences, turn the "Camera Pivot Speed" slider down to a bare minimum. It starts pretty low already at a default of 6%, but turn it down even more. I set mine down to 3-4% and suddenly my movements using the mouse to turn were much smoother and more like other games. It will eliminate the too fast spinning movement and make gameplay more standard.

To BioWare: please consider either adding a separate slider for turning via mouse sensitivity or turn down, internally, the camera pivot speed. The default of 6% is way too "loose" and doesn't leave much room for improvement by turning it lower. Anything above 10% makes the game essentially unplayable using the right mouse button for turning. This obviously needs some adjustment.

Poin_Dex_Tenobi's Avatar

12.14.2011 , 02:18 AM | #2
Thanks for the heads up, will try this out once i get into the game.

Elveleg's Avatar

12.14.2011 , 03:10 AM | #3
I have set mine to 0-1% to be able to soak in the scenary. Also is more equivalent to my other MMOs playstyle (lotro)

Tintagel's Avatar

12.14.2011 , 03:57 AM | #4
The Red Eclipse - EU

Amarinth's Avatar

12.14.2011 , 03:59 AM | #5
Fast-turning camera's in games annoy me to no end (I get disoriented really easily if the camera turns too fast). I had to turn it down to 2% to be bearable with the sensitivity of my mouse, and I'm only at 50% of the max DPI of my mouse... I pity the folks who use a really high DPI.
We all have our heroes. And when we watch them fall, we die inside...

Frigidman's Avatar

12.14.2011 , 09:58 AM | #6
I don't know how many times I personally reported this ~flaw~ during beta, or how many times other people brought it up in reports or on the forums (saw it often).

Curious why (or HOW??!!) bioware can think any setting above the 10% mark is even remotely playable. The scale of choice on that bar is ridiculously skewed. I have to personally run at 1%. Which gives very little room for fine tuning. Grr.

Hire website designers that actually have had real life experience in the job.
Then let me know so I can return to the forum.

galadiman's Avatar

12.14.2011 , 10:20 AM | #7
/Signed. BW, please tune down the mouseturn speed so the current 10% speed is the max, (for example - maybe 15% should be the upper limit, but I have trouble imagining how anyone could play above 5% effectively.)
Don't let the size of Someone Else's Special Snowflake make you feel bad about the size of Your Special Snowflake.

Morolac's Avatar

12.14.2011 , 02:17 PM | #8
was looking for a fix. Will try that out when I log on again.

Maybe Bioware and Bethesda should compare notes...
In Skyrim the mouse sensitivity was abysmal and in SWTOR I do a 180 just by bumping into the mouse.
Keep your feet on the ground and keep reaching for the stars.
Casey Kasem

Wapner's Avatar

12.14.2011 , 09:39 PM | #9
Agreed. Same issue here. For me, even 0% is too fast...I have a 5000 DPI mouse set at 800 DPI and can barely handle it.

starwarstannith's Avatar

12.14.2011 , 10:36 PM | #10
i thought it was just me in beta... im really glad to know its a bigger issue and not something wrong with my pc. Thanks for the head sup on how to slow it down a bit.. it was really hard to play that way!