Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Nvidia driver issues


Paladins_Strife's Avatar


Paladins_Strife
01.09.2012 , 06:18 AM | #11
Quote: Originally Posted by GarmiMobar View Post
Hi, when you guys refer to the latest driver, are you talking about the beta driver 290.53? I had installed 280.26 with my GTX550Ti and got that problem too...:



Yesterday I installed the 285.62 version and I still got the same problem. Should i change to that 290.53?
Personally, I dislike beta drivers, that's not to say there is anything wrong with them, just a personal preference. I am finding the 275.33 to be stable. You could always give the beta drivers a shot and see how they work for you though, can't hurt.
"If that thing eats us you're fired" ~ Master Orgus Din

Alkiii's Avatar


Alkiii
01.11.2012 , 02:32 PM | #12
My son was having "video driver has stopped working" messages every so often while playing SWTOR (280.26 drivers). I updated my son's drivers to the 290.53 beta drivers, and everything has worked good since.

His specs:

E6600 Core2Duo @ 2.4Ghz CPU
Asus GTS450 TOP GPU
8 GB DDR2 Kingston HyperX RAM
Windows 7 HP
240 GB HDD @ 7200 RPM

Hoping there is an updated driver soon with some kind of optimization. Fleet and Warzones are slamming his system down to the mid teens or single digits FPS.
“When I die, I want to go peacefully like my Grandfather did, in his sleep ... not screaming like the passengers in his car.”

magecutter's Avatar


magecutter
01.11.2012 , 04:13 PM | #13
had the same prob w/the 280.26 driver (GTS 360m) not a fan of beta drivers but tried the 290.53 and have had a huge improvement in fps and stability in game and out of game no longer getting nvidia based bsod's.