Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

32 and 64 bit dif clients? / new problem: DX9-DX11

STAR WARS: The Old Republic > English > Customer Service
32 and 64 bit dif clients? / new problem: DX9-DX11
First BioWare Post First BioWare Post

MadJackxD's Avatar


MadJackxD
01.04.2012 , 10:05 AM | #1
I just upgraded to a new PC, in my old one that i was playing SWTOR it was running under windows xp 32bit, and this new one is running under Windows 7 64bit.

I just went ahead and copy the game folder to my new harddisk, because downloading the game again will take me like 3 days(nights while im sleeping, crappy internet conection) worth of download, and I just odnt want to dl again.

The launcher not allowing me to hit the play button thats why im wondering if theres any difference in the clients, or maybe something in the registry, any help would be appreciated

FIX: Fix launcher 3 times
NEW PROBLEM: Keeps looking for DX9, maybe change directx.version for DX11?
FIXED: Just wait A LOT for the launcher to pop a DX installer and done.

Tkara's Avatar


Tkara
01.04.2012 , 10:07 AM | #2
Did you right click on the shortcut and select Run As Admin?

Kalten-Siduri's Avatar


Kalten-Siduri
01.04.2012 , 10:10 AM | #3
I do not believe there is any difference for SWTOR, I safely copied my download of the game to my mates, and my missus' PC in order to save them downloading it.

I would try running the repair tool from the SWTOR folder.

It's called FixLauncher.exe (Do a search for it if you can not find it)

The game client should then look for the bits it needs and redownload them if it can not find them - this might still take some time if the game thinks there is corruption or somesuch with your files.

Good luck and let us know how you get on!
Anyone for a Monkey?

Tirvaak's Avatar


Tirvaak
01.04.2012 , 10:24 AM | #4 This is the last staff post in this thread.  
Quote: Originally Posted by MadJackxD View Post
I just upgraded to a new PC, in my old one that i was playing SWTOR it was running under windows xp 32bit, and this new one is running under Windows 7 64bit.

I just went ahead and copy the game folder to my new harddisk, because downloading the game again will take me like 3 days(nights while im sleeping, crappy internet conection) worth of download, and I just odnt want to dl again.

The launcher not allowing me to hit the play button thats why im wondering if theres any difference in the clients, or maybe something in the registry, any help would be appreciated
Hi MadJackxD,

Sorry to hear you are having a problem with swapping your client from one operating system to another.

Please make sure you are running the launcher with admin rights, while this may not be the problem it is one possible option to try.Also as you have installed the game on a new system you may need to add swtor.exe and launcher.exe to the exceptions list of your firewall program.

If you are still encountering this while running as admin then you may need to run the repair tool as mentioned by Kalten-Siduri.

I hope this helps.

Tirvaak | Bioware Customer Service - Forum Support

MadJackxD's Avatar


MadJackxD
01.04.2012 , 10:28 AM | #5
Still not working.

Maybe its a registry entry issue since i didnt install it, just copied it ?

Tronics's Avatar


Tronics
01.04.2012 , 10:30 AM | #6
As the original post says but wasn't asnwered by any of the tech peeps, does the game have a 64 bit client? yes or no because on your box for this game it says 32 bit and 64 bit os

Kalten-Siduri's Avatar


Kalten-Siduri
01.04.2012 , 10:31 AM | #7
Quote: Originally Posted by MadJackxD View Post
Still not working.

Maybe its a registry entry issue since i didnt install it, just copied it ?
Did you run the fixlauncher I mentioned?

If so, did you try it with Administration rights? (as per the droid above)?
Anyone for a Monkey?

Tronics's Avatar


Tronics
01.04.2012 , 10:31 AM | #8
Re-install it


Quote: Originally Posted by MadJackxD View Post
Still not working.

Maybe its a registry entry issue since i didnt install it, just copied it ?

Kalten-Siduri's Avatar


Kalten-Siduri
01.04.2012 , 10:33 AM | #9
Quote: Originally Posted by Tronics View Post
As the original post says but wasn't asnwered by any of the tech peeps, does the game have a 64 bit client? yes or no because on your box for this game it says 32 bit and 64 bit os
Whilst not a techpeep.....I guess you mean the Bioware Droid? I did answer that question - though it was not a definate answer - only that I believe there to not be a difference

The game does get installed into the program files x86 folder on a Windows 7 64bit client so from that I would guess it's a 32bit application only.
Anyone for a Monkey?

Tronics's Avatar


Tronics
01.04.2012 , 10:37 AM | #10
I know copying the 32 bit software to the 64bit pc isn't going to work and will cause more problems, so it's best just to re-install it all. I just wish these firms were a little clearer when it comes to wha swtor will run on.