Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

The Foundry

Albytaps's Avatar


Albytaps
01.04.2012 , 08:02 AM | #1
So yesterday my guildmates and I ran Boarding Party quickly and successfully for the first time. We got through it with no wipes. After that, one group member left (a healer) but we still had one of each role (Tank, Healer, DPS) so we decided to try it with a companion.

It went great until we got to the second boss (some droid that talked too much.) At this time we realized how hard it was to do our own job and control our companion as well. We had a dps companion out but it got killed when it kept attacking when it should have stepped back. Then we brought out a healing companion and that went better but we still failed. I think if we would have tried it again it would have worked.

We did try to get another person to fill another role (we didn't care what it was as long as it wasn't dumb AI.) Someone volunteered to join but they could join the party? ***? They said they were on the same quest but something wasn't letting him join. What's the deal? Were we on different parts of the instance and wouldn't let us group together? What's wrong with this flashpoint?
THE 8-BIT COALITION
A MATURE GAMERS' GUILD