Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

78 bugs/issues + concerns (3-day period)

STAR WARS: The Old Republic > English > General Discussion
78 bugs/issues + concerns (3-day period)

Ilsildor's Avatar

01.03.2012 , 09:39 PM | #1
Been documenting whatever I personally ran into over the past 3 days, plus some personal concerns of mine. Pardon a lot of my WoW terminology, old habits die hard (especially in a game that's so similar)

Sith Juggernaut - Levels 32-42

- Guild roster interface sometimes displays the incorrect members online. UI must be reset to remedy the issue (doesn't always work in some circumstances)
- Item Stat Comparison usually incorrect / bugged, displaying stats from different items on one.
- When Dragging items off hotbars, it asks if you want to destroy the item (even if you have none left)
- Some attack animations repeat for no apparent reason, (highly noticeable with ability delay on)
- Camera drifts away sometimes on its own for a few seconds till it snaps back to the character.
- Sometimes Tooltips stick on your screen till you highlight a similar tooltip again.
- When right-clicking items in your bag to transfer to cargo hold, items don't stack properly.
- When splitting stacks via Shift+Click+Drag, item is linked into chat.
- Party members sometimes do not correctly display their correct amounts of resources in their resource bar. (usually as 0)
- When sending a mail to someone, if you right-click an item into the letter it will create the subject line as the name of the item. However it doesn't count as a proper name and still must be edited before being able to send. (unable to verify if this bug still exists, as mail doesn't work)
- When clicking any mouse buttons other than Left-Middle-Right, your entire UI becomes unclickable till you press some combination of extra-mouse buttons to return functionality

- no /roll for random number generator in game
- Auction House Interface drastically needs improving, at least a search option from the getco, remove the need for selecting categories.
- When backspacing all digits in an AH sale, it defaults a 1 there. That is unnecessary and annoying.
- Guilds lack:
- Log - for displaying invites/kicked/promotions/etc.
- Bank - for sharing items/credits among your guild, with options and tabs.
- Quality Guild Information tab/description. Unable to copy+paste information from these boxes, they're too tiny as well (even in the expanded view).
- Unable to overlap tabs, this becomes incredibly annoying with Crew Missions. Whether you're browsing the GTM, or trying to decide what item to select - once another tab pops up it closes your other tabs.
At least your bag should be seperate from all other tabs.
- Unable to Bind Keys to "marking targets", forced to use laggy drop-down menus.
- No Combat-log making it difficult to determine a lot of things in this game.
- Being unable to create macros, causing hassle to perform many tasks.
- Being unable to raise/lower hood, cosmetic disappointment (over helms as well)
- Being unable to hide companion's helm/hoods is disappointing as well.
- Small HP bars, inability to scale/customize UI causes difficulty
- Addons (I feel the inclusion of add-ons is important as you currently have a LOT of faults in this game - and focusing your work on fixing UI errors while players could do it for you seems silly to me. Go fix the real bugs and let us fix your UI.)

General Gameplay
- Enemies/Friendly NPCs that attack your targets, tag your targets from you.
- Sith Corruption doesn't stay turned off
- Off-GCD abilities start a GCD if not used during a GCD.
- Crew skils doesn't correctly display the amount of items you can craft sometimes.
- Moving your character immediately after the Mount casting is completed, dismounts you.
- Tab Targetting sometimes doesn't work at all, or will not cycle through all available targets. (3 melee in front of you, cycles back and forth between 2)
- Gathering Nodes sometimes spawn underground.
- Unable to abandon some Bonus Quests, or Bonus series - taking up sometimes valuable quest space (25max)
- Mobs sometimes reset when a companion pulls threat (companions appear to bug out in the environment quite a bit)
- Companions sometimes disapearing completely.
- Companions sometimes going invisible.
- Companions getting stuck behind in hallways/elevators.
- Companions sometimes being unable to be dismissed, especially after getting stuck.
- Unable to Guard targets sometimes, cause unknown - states target is already guarded (when it is in fact not)
- Unable to Static Barrier targets (same issue as above), these usually cannot be fixed without having to log out
- Companion portraits display incorrectly, nearly all the time.
- Quinn's base portrait doesn't resemble his character.
- Commanding a summoned companion to sell trash items, often doesn't work. Companion must be dismissed then sent away via Crew Skills tab.
- Sith Robot Companion annoying as f- Excellent! I was just wondering what I could do to please you!
- Companions often say the inccorect lines on mission success/failures. (Success = I'm sorry master, I've failed you / Failure = I don't think I could've done it any better master!)
- Quick travel's cast bar begins when clicking the ability, instead of when you select where you want to QT to.
- "Ability Lag", delaying the cast of some abilitys - appears to be affected greatly by poor fps
- When engaging in combat, companion almost never targets the enemy you engaged on.
- When commanding a companion to switch targets, they stand around for about 3 seconds before doing sometime.
- Bugged Gathering nodes still exist, appear on minimap and visually but untargettable.
- Sending summoned companion out on a mission, then summoning a different companion to aid you in combat can cause the first companions mission timer to remain over the portrait.
- Sometimes unable to summon a companion at all (unknown cause) forced to logout
- Companions may sometimes fall through the floor and take damage/die
- Sometimes when casting a channelled abiliy, your character will begin the animation but won't actually cast the animation. Unless cancelled via casting another ability, you'll be stuck in the animation till fake-channel is completed.
- Auto-target when ability is cast sometimes switches targets randomly / targets friendly units (hostile action) / targets dead bodies.
- When beginning a Quest Dialogue while on your mount, it dismounts you and summons your current companion but companion will not be present in dialogue. Forced to manually dismount before beginning dialogues to include companions.
- Depth Perception of the Imperial fleet while aboard your ship is incorrect. Star Destroyers appear as if tiny floating toys outside your window. (aka, they shouldn't move so much when you strafe back and forth)
- Follow Target doesn't work
- Sometimes unable to hand in missions into drop-boxes, drop box doesn't display as being interactable untill re-log.
- Group Quest Dialogue sometimes shows group members as a Holo-call when all members were physically present.
- Mail doesn't work

- Southern Door into the Imperial Cantina upon arriving on Quesh doesn't open, but you are still capable of walking through the door physically. (I'm a ghost! :O)
- "Unable to see targets" 22,797

Mandalorian Raiders (Instance)
- Knocked mob out of instance area with Force Push (near the end) and he got stuck under the map and was firing at party. Was unable to target or reach him even.

Cademimu (Instance)
- Turret knocked me into the wall, got stuck.
- Mobs Evade for no reason, pack respawns
- Companions fall off elevators and nearly/kill themselves when player is standing still
- Final Boss room sometimes ignites players on fire before/after combat with no animation. Players receive damage and eventually die unless engage boss / leave room.

- Encountered Rock with no texture
- In Caves, the edges appear partially see through which produces a "dotted line" effect.
- Green lines appeared to be floating for a significant amount of time (appeared to be a spell effect of a mobs ability)

- Floating Trees discovered
- In the quest where you can kill Thana before evacuating the facility, if you force push her off the edge she'll die, but won't count towards quest completed - must reset quest
- In that same quest, when you're told to kill Cerik - he stands in a Window. You're able to jump on the boxes, and attack him from below which causes him to run through the locked door and fight you while skipping all of his minions.

Graphics Issues
- No options for rendering particle effects, significant amount exist in game and aren't optimized very well for some computers

Balance Issues
- Some Heroic quests feature multiple Elite mobs (6), all ranged and spread out. Impossible to tank.
- Threat seems to be on the low side for tanks, at least Juggernauts in my experience. Not enough options for generating threat reliable, especially in groups or at range.

And I don't even do PVP, nor documented any of the zones before Alderaan. I could only imagine what else I've been missing... =/

Ilsildor's Avatar

01.03.2012 , 09:57 PM | #2
I'm really hoping Bioware states a fix for a good amount of these bugs soon =/

Havokk's Avatar

01.03.2012 , 10:10 PM | #3
Keybind issues.

• Next and Previous Target functions do not work if bound to anything other than Tab. This sucks for people wanting to use IJKL instead of WASD.
• Backslash (\) always creates a new help ticket, even if you bind it to something else or don't bind it at all. You are in trouble if you hit it by mistake in combat since the window cannot be closed by keys - it requires 3 mouse clicks.
• The keybind Target Self doesn't actually target yourself - it toggles between self and companion. Do not hit it multiple times in a panic and expect your toon to be selected.
• Minimap Zom keybinds (+ and -) do not seem to do anything.
• No keybind for Who and Ignore tabs in the Social Window.
• No keybind for Party, Codex and Lockouts tabs in the Mission Log Window.

Trade Network

• Can't browse items by slot. For example, if I want to buy a new pair of boots I have to look at items for all slots. I believe being able to search for "boots" is a minimum for a trade system. I think being able to search for "boots that give me Strangth" is also a fair expectation, since this is 2012 and MMOGs autions have been around for a couple of decades.
• "Usable by me", "Usable by Companion X" don't work. They always filter every item out of the list, displaying nothing. This is a basic feature that should just work.


• Selecting "usable by me" doesn't work. It does not seem to filter at all. If I am a light armour wearer then I should be able to filter out medium and heavy armour. If my Artifice crew skill is 120 then I should be able to filter out recipes that require higher skill. Again, this is a basic feature that should just work.


• If you open the Social Window then select a different tab then close the window, opening the Social Window again will always take you back to the Friends tab. If you open the Inventory Window then shooce a different tab then close the window, opening the Inventory Window will take you to what tab you chose before. Inconsistent. I don't remember how the Mission Log Window behaves.
• If you are browsing the GTN and another window pops up (for example, Crew Skill mission completion) the GTN window is closed. Annoying. When you open the GTN window again it does not take you to the search you had open before - you have to re-enter all the search parameters again. Highly annoying.


• It is not just heroic quests that are sometimes unbalanced. I have found a small number of quests that are labelled, say, "level 28" in the log but that require fighting multiple level 28 elites that can't be individually pulled. One level 28 elite is too much for a level 28 quest, multiple elites is just a joke.

In Summary

The story is awesome, the companions are great, the locations feel like iconic Star Wars sets.

However the mechanics of the game are lacking. The UI in particular feels like nothing has been learnt from the last decade of HCI in MMOGs.

Ilsildor's Avatar

01.03.2012 , 10:25 PM | #4
Good additions, I wouldn't of noticed a lot of the keybind issues. (Your formatting is neater ;P)

Aendos's Avatar

01.03.2012 , 10:50 PM | #5
Great list, more should add their additions.

Sephrinx's Avatar

01.03.2012 , 10:56 PM | #6
And I thought Beta testing was Over...LOL
"I shot first."

Ting's Avatar

01.03.2012 , 11:04 PM | #7
Working as Intended (adopted from EA/Mythic)

JasonFJ's Avatar

01.03.2012 , 11:33 PM | #8
An excellent summary of most of the bugs I also see.

I am still enjoying the game and most have a workaround. I hope they are fixed quickly but compared to most other MMO launches I've experienced these aren't too bad! (WoW, Lineage 2 and SWG had much worse bugs).

Having said that some observations:

- When splitting stacks via Shift+Click+Drag, item is linked into chat.
Me> Use the right mouse button and it won't link to chat.

- no /roll for random number generator in game
Me> Agreed. I'd like to add that a light armor user should never be able to Need for a heavy armor set. e.g. if you're character can't use it, you shouldn't be able to roll. Companion gear needs should be satisifed by Greed.

- Unable to abandon some Bonus Quests, or Bonus series - taking up sometimes valuable quest space (25max)
Me> Not just bonus quests. There are quests in Alderon and Quesh that can't be abandoned either. I think they are a storyline mini-arc and if so they should have a category "Storyline".

- Sith Robot Companion annoying as f- Excellent! I was just wondering what I could do to please you!
Me> Republic ship robot also annoying as hell. Customization options needed, including one for minimal talk!

- Some Heroic quests feature multiple Elite mobs (6), all ranged and spread out. Impossible to tank.
Me> Tattooine by any chance? Sometimes the player skill required is knowing what groups NOT to fight. Try avoiding the group or look for an alternative entrance to the area (hint).

No keybind for Who and Ignore tabs in the Social Window.
Me> "Who" is bindable. I do it myself.

Extra bugs:

-If you order your companion to attack a target, then cast force bubble on them, you'll aggro all mobs even if your companion hasn't engaged yet.

Vegetian's Avatar

01.04.2012 , 12:02 AM | #9
Yes, I've noticed around the same bugs listed in this thread (various posters). As well as the need for the proposed changes that need to be done.

I've actually ran into a new one today, in regard to flashpoints/group quests. So far the "reset" button for group quests/flashpoint quests hasn't worked for me. This was the case with the Insufficient staff quest on Alderaan, we eventually had to all re-log to fix the quest.

The 2nd issue was with the Boarding party mission for the White Nova. Apparently we could not enter the phase because our group leader already had the phase in process. So even after resetting all phases thru the character portrait (which is what the error message said to do), dropping quest, dropping group then dropping quest (new lead invite), and re-log we still couldn't get into the flashpoint. This was compounded when I tried to enter the phase solo, and recieved the same error message (which technically shouldn't happen).

Naturally I looked on the known threads stickie..not on there, so submitted a bug report. Now if this is a widespread bug (not sure, was on my server and everyone in the zone couldn't get in, Veela server), thats a big issue considering the White Nova FP involves ***spoiler**** Revan and his story, which BW has tried to highlight.
“The customer is always right!”
No, the customer is usually an idiot who has no clue.

Vegetian's Avatar

01.04.2012 , 12:10 AM | #10
Quote: Originally Posted by Ilsildor View Post
I'm really hoping Bioware states a fix for a good amount of these bugs soon =/
Woudln't count on it. Thier busy doing maintaince as well as rolling out new content near the end of the month. My confidence in the success of this is almost non-existent...considering the massive amount of issues you've listed (most of which I've seen or experienced myself) as well as various other issues out there (reference my prev post, and other posters).
“The customer is always right!”
No, the customer is usually an idiot who has no clue.