Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Master Looting is hardcore broken

MacAllen's Avatar

01.03.2012 , 12:42 PM | #1
We set up Master Loot for EV last night (sucks that there is no /roll or /random). We looted a chest. The ML assigned things to people...and they didn't go. In addition, he tried assigning the pre-assigned drops and there was no option to do so. People tried to loot their pre-assigned or assigned things and it failed. No one could get anything.

The only way we could distribute loot was to make each person raid leader and let them loot the chest.

Call me kooky, but that sort of defeats the purpose of Master Looter, at least to me

Jaev's Avatar

01.03.2012 , 04:20 PM | #2
Wish I had known about this last night when Myself and others were unable to loot from chests with ML set. No one thought about passing lead. Really incompetent of this company to not test this out before release. maybe they foolhardily thought no one would be raiding the first couple weeks and they'd have time to fix bugs.

MacAllen's Avatar

01.03.2012 , 04:21 PM | #3
We're all friends so there was no concern, but without /rand there was confusion with the round robin, so we just decided to ML. Our first time. It's SERIOUSLY broken

phlowbies's Avatar

01.03.2012 , 04:28 PM | #4
Working as intended. "Normal" mode is equivalent to WoW's LFR difficulty, aka no difficulty. Catered to pugs/casuals etc.

Chests have a tendancy to bug out if you don't one-shot the encounter. Which really should happen anyway.

MacAllen's Avatar

01.03.2012 , 04:30 PM | #5
Not sure what you mean by "working as intended". As the Master Looter, I assigned loot to people and they did not get it nor could they loot it, or the loot that was there for them. The only way they could get their loot is for me to make THEM the master looter.

How is this "as intended"?

phlowbies's Avatar

01.03.2012 , 04:31 PM | #6
Master loot isn't supposed to be active in normal modes. Sometimes loot does bug out, but the whole ML thing, don't even bother with it.

MacAllen's Avatar

01.03.2012 , 04:33 PM | #7
So how is it "working as intended" when it's "not supposed to be enabled"?

Trayne_'s Avatar

01.03.2012 , 06:26 PM | #8
Switch to hard mode. Problem solved.
Lvl 50 Mercenary
Daragon Trail

KaiHeilos's Avatar

01.03.2012 , 06:29 PM | #9
So many trolls in a legitimate thread.