Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher not opening.

First BioWare Post First BioWare Post

liquidis's Avatar


liquidis
12.13.2011 , 12:03 PM | #11
bump.

Packetdancer's Avatar


Packetdancer
12.13.2011 , 12:09 PM | #12
Quote: Originally Posted by liquidis View Post
I'm having the same problem. Launcher won't open, task man says its running in processes, nothing happens, pi$$ed off. I've tried all the things you guys have suggested with no luck. I've tried the launcher fix, deleted the patch folder, re-installed, checked fire wall. all that nonsense. Nothing. Anybody got any other ideas? The phone line is unavailable apparently cuz of the high volume of calls (imagine that). This launch is shapin up to be even worse than BF3 and that was a mess! Pull ur head out of your ***** EA and do somethin about it!
I tried to collect common problems and their fixes in one thread here once the forums came back; maybe one of those will help?

Short form, though, is that if there's no patch directory and FixLauncher or a reinstall of SWTOR_setup.exe doesn't work for you, I'd probably do the following:
  • Double-check that you don't have anything pending in Microsoft Update. The launcher's sensitive to .NET Framework 4 being out-of-date, among other things.
  • Make sure your Java installation is up-to-date as well, as the launcher uses java in part of the patching.
  • Blow away your launcher.settings file
  • Blow away the C:\Users\<youraccount>\AppData\Local\SWTOR directory if one exists.

Hope one of those helps.
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

shurikt's Avatar


shurikt
12.13.2011 , 12:10 PM | #13
It could be a conflicting device driver. Does the launcher show up in Safe Mode + Networking?
Check out Packetdancer's awesome game install/launcher troubleshooting guide: HERE.
Squadron 367

Xaryell's Avatar


Xaryell
12.13.2011 , 12:14 PM | #14 This is the last staff post in this thread.  
Hi guys,

For anyone experiencing this issue where the launcher does not appear but shows up in the Task Manager, and there is a 'Patch' folder in the installation directory. It means that you most likely did not completely uninstall an outdated version of the game from the testing phase.

Deleting the patch folder and running the FixLauncher.exe located in the installation directory should allow you to gain access to the game, however it is possible that you could encounter further difficulties due to the old installation on your system. A full uninstall (including manual deletion of any remaining folders) and reinstall will be the safest option in the long run.

If you are experiencing this issue and you do not have remnants of an outdated installation, then it is possible that you need to update your Java.

I hope this helps.

Xaryell | BioWare Customer Service Forum Support

buusey's Avatar


buusey
12.13.2011 , 01:15 PM | #15
Just found out that the reinstall option was only a temporary fix. Going to try deleting the patch folder now, even though the only beta I played and installed was the one over Thanksgiving weekend.
Sup.

beatslave's Avatar


beatslave
12.13.2011 , 02:54 PM | #16
Bump. Having the same problems.

Tried all of those things above.

DarthArcon's Avatar


DarthArcon
12.13.2011 , 06:21 PM | #17
Bump. Same here.

I updated .NET v4 and that actually got the launcher to load its GUI...once. It said it was updating the launcher and then the GUI closed (but the program did stay in memory). Sat there for 15 minutes, gave up, forced it to terminate, and then ran it again.

The launcher GUI loaded a second time, but then it crashed. Now its doing the sitting around in memory forever...again. NOOO! I was so close!

DarthArcon's Avatar


DarthArcon
12.13.2011 , 08:31 PM | #18
Yeah...Its Avira. Disabling it and/or putting 50 exceptions in is apparently not enough. You have to completely uninstall it. *sigh*

Ok, Im never using Avira again. This isnt the first time it has messed up stuff.

skyrazar's Avatar


skyrazar
12.13.2011 , 09:25 PM | #19
having same issues , did everything on this page and the launcher.exe still just sitting there on the task window stuck at 29,240k mem usages.

DarthArcon's Avatar


DarthArcon
12.13.2011 , 10:51 PM | #20
Quote: Originally Posted by skyrazar View Post
having same issues , did everything on this page and the launcher.exe still just sitting there on the task window stuck at 29,240k mem usages.
What anti-virus and/or firewall(s) are you using?