Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Graphics Tips - NVidia & ATI (Gain FPS and Quality)

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Graphics Tips - NVidia & ATI (Gain FPS and Quality)
 

vincentvang's Avatar


vincentvang
01.01.2012 , 09:34 PM | #21
Quote: Originally Posted by Sallanon View Post
The only option it gives me is to run the Compatibility mode for Windows XP service pack 2


Same here, should we just DL xp serv pack 3 from windows?



Thanks for guide, seems helpful, hopeful to try it if I can find out about serv pack

carnac_fett's Avatar


carnac_fett
01.01.2012 , 09:59 PM | #22
I had a problem with awful-looking textures that I solved myself a few days ago by running the game in Windows XP SP3 compatibility mode.

So I can definitely say the option does something. Here's the thread I made about it if anyone wants to check it out.

http://www.swtor.com/community/showthread.php?t=102942
Safeguard - Jedi Guardian - Harbinger (US)

LiquorQ's Avatar


LiquorQ
01.01.2012 , 10:08 PM | #23
Neither of these things worked for me. Didn't increase or decrease my fps. The only thing that happened was with the scaling, and it not scaling 1280x800 to my display. And that's only because you tell it not too.

Quote: Originally Posted by withorwithout View Post
Trying your fix-- but I only get a compatability option for xp service pack 2 (no 3). Also, (and I have the latest versions) the Nvidia control center doesn't have the option to overrride--I have it set to no scaling, perform scaling on Display--but there is not box to tic to override other programs--Any ideas?
I have the same deal as this guy.
while(trolling = 1) {
cout<<"You mad bro?"<<endl;
cin>>youMad;
}

sciiwalker's Avatar


sciiwalker
01.01.2012 , 11:17 PM | #24
Tried this bogus "fix" on 2 different PCs, each had WORSE performance.

Anyone saying this works is merely experiencing a placebo effect.

GGTeMpLaR's Avatar


GGTeMpLaR
01.01.2012 , 11:28 PM | #25
My compatibility modes only go up to Service 2, not Service 3

Draccman's Avatar


Draccman
01.01.2012 , 11:31 PM | #26
When I try to change scaling to display I dont have the option to, there is only GPU.
trololol

Vhyle's Avatar


Vhyle
01.01.2012 , 11:38 PM | #27
Quote: Originally Posted by sciiwalker View Post
Tried this bogus "fix" on 2 different PCs, each had WORSE performance.

Anyone saying this works is merely experiencing a placebo effect.
I can state for fact, that my fps increased by about 10-20 more than what I had before doing this. Before hand, I was seriously getting 10-20fps consistently. After I applied the tips I get 25ish - 40fps standing still and running around, and 15-30 in combat. It's not a huge increase, but I can say that the game itself performs much better. There used to be a ton of what I call "hitching and stuttering" but now it's performing very smoothly.

At least for me, it's not the "placebo effect" because I noticed an immediate impact on the games performance. My processor was struggling, and more than likely still is, struggling to run the client, but at least now it's been eased off.

The above results are with every effect on, and set to high with shadows turned off. I played with everything medium to low and had a huge FPS boost, but the game wasn't pretty.

When I pvp or go into Operations I'll be setting it as low as possible so that I can enjoy the experience. The game, at least in my opinion, doesn't look half bad on low anyway.

I will not deny there is more Bioware can do to increase performance, because there is certainly more that can be done to get it to perform much better. I'm still having fun and enjoying the game.
"can you make sword in box light sword so sword come out when opened? then if sword is back after sword, use light saber on box, and saber will be boxed after sword is out." - battlebug

imzo's Avatar


imzo
01.01.2012 , 11:47 PM | #28
can anyone post a link for windows xp sp3 for vista. ive downloaded it but after extraction it cannot install saying its the wrong version of windows.

do they make a version that can be 'retrofitted' to vista??

Lord_Itharius's Avatar


Lord_Itharius
01.01.2012 , 11:48 PM | #29
I followed these steps, didn't help me. :-(
"can you make sword in box light sword so sword come out when opened? then if sword is back after sword, use light saber on box, and saber will be boxed after sword is out." - battlebug

poasiodss's Avatar


poasiodss
01.01.2012 , 11:56 PM | #30
Hm, I'd love to try out this fix, but I am having few some issues getting the game to work on XP SP3 compatibility.

First of all, the launcher does not seem to work with XP SP3 compatibility mode on (I've tried with just XP SP3 mode, XP SP3 + Admin, and XP SP3 + Admin + Disiable Visual Themes + Disable Desktop Composition). The launcher starts, and I can see it on the processes in Task Manager, but it doesn't actually pop up on my screen.

I tried keeping launcher on the default settings but changing my swtor.exe (it's located in C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient for me) to XP SP3 mode. In this case, the launcher works properly but the game itself crashes on the loading screen. I can't seem to make it work even after fiddling with the compatibility options I've tried for the launcher.

Do you have any suggestions for this issue?

Edit: Oh, also I'm running Vista 64 on a laptop.