Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher - Server Not Responding

First BioWare Post First BioWare Post

hillm's Avatar

12.30.2011 , 11:32 PM | #1
Earlier today I installed Star Wars: The Old Republic. As far as I am aware the install went fine; there were no problems. I started it up and tried to log on and was greeted by a red bar and the error "Server not responding."

I looked around on the internet and wasn't able to find much that was helpful. I tried restarting my computer, running in compatibility mode and running as administrator. I checked my firewall and it was allowed. I pinged the server, although I forget what it was, but got a quick response.

I called customer support twice. The first time a lady told me I had to enter subscription information, either via credit card, paypal or a time card. I thought that sounded kind of bogus but I went along with it. It didn't help at all. The second time a man put me on hold for 5-10 minutes and when he came back he told me the technical team was working on it and there was nothing he could do.

I am leaving for boot camp at the end of January and want to be able to play this game some before I leave. I think it is ridiculous that I payed $60 so I could play this game some over the next month and I can't even log in. I would greatly appreciate some help with this issue.

Here is an image of the error.

Here is my log file:


I went ahead and posted the entire thing since I have been getting the same issue from the start. If anyone needs any more information let me know. Thanks.

Ratae's Avatar

12.31.2011 , 12:02 AM | #2 This is the last staff post in this thread.  


Please ensure that you have the correct ports opened in your router settings. See this link: and that you have both the launcher.exe and the swtor_setup.exe added to the exceptions of your firewall and any antivirus software.

Check also the Launcher Troubleshooting Guide:
Finally could you check that the date and time are set correctly on your computer.

If none of these steps help you, please post your Dxdiag report here.
For details of how to obtain this, please see this link

Thank you for your help.
Ratae | BioWare Customer Service - Forum Support