Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Black screen at start


Hirtski's Avatar


Hirtski
12.30.2011 , 06:30 PM | #1
I have recently purchased and downloaded the game but every time I open the client and hit play the screen goes black but the sound continue. Is this just a GPU update error? ( I downloaded an driver update before I even started the game setup.)

Please help me so I can play and get away from wow!

dodgygeeza's Avatar


dodgygeeza
12.30.2011 , 06:30 PM | #2
Post your dxdiag.

crzybluesmrf's Avatar


crzybluesmrf
12.30.2011 , 06:32 PM | #3
1. dxdiag (start, search dxdiag, hit enter)
2. client_defaults.ini (C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\client_default.ini)
3. crash log (C:\Users\<YOUR USERNAME>\AppData\Local\SWTOR\swtor)


place each of these in their own [spoiler][\spoiler] tags

Hirtski's Avatar


Hirtski
12.30.2011 , 06:48 PM | #4
Spoiler



Spoiler




And I do not have a crash log folder, at least that I can see anyways.

dodgygeeza's Avatar


dodgygeeza
12.30.2011 , 06:48 PM | #5
Your drivers are old, try these beta drivers http://downloads.guru3d.com/AMD-Cata...load-2826.html

Hirtski's Avatar


Hirtski
12.30.2011 , 06:54 PM | #6
Uhhh I have to pay for those don't I?

dodgygeeza's Avatar


dodgygeeza
12.30.2011 , 06:55 PM | #7
Quote: Originally Posted by Hirtski View Post
Uhhh I have to pay for those don't I?
No, scroll down to a mirror, don't download any of the junk advertised on the page.

Hirtski's Avatar


Hirtski
12.30.2011 , 07:25 PM | #8
Well Ill try it out, If this doesn't work and it isn't fixed by next week I'm just going to have to fight for a refund or something.

ccline's Avatar


ccline
01.01.2012 , 09:01 PM | #9
I am having the same exact problem. Black screen on startup.

I will download the preview driver and let you know the results

Paralassa's Avatar


Paralassa
01.01.2012 , 09:03 PM | #10
Hi there!

We're very sorry you're having this issue. Our Customer Service droids have some helpful posts regarding this issue that you may want to check out:

Black screen after clicking 'Play' in the launcher

If you are still encountering this issue after checking all of the above, please contact Customer Support, by either replying to this thread or sending an e-mail to support@swtor.com. Please include a DXDiag of your system, your most recent client logs and a description of the exact error encountered (if any). You can find instructions here on how to do that.