Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher get stuck downloading the game. FIX!

STAR WARS: The Old Republic > English > New Player Help
Launcher get stuck downloading the game. FIX!

TyronWind's Avatar


TyronWind
10.15.2015 , 05:33 PM | #1
Hey, guys.

I just wanted to share the solution to a problem I've been having last couple of times I install SWTOR. All those launcher repair tools and stuff wasn't helping and if you're reading this, I assume you've done some research as well before getting here.

The Problem:
Your launcher will update itself normally and you will be able to login normally. The launcher will activate the BitRaider to download the game and the current patch; however, the BitRaider don't always work (it might be your firewall, operational system, whatever) and you can leave the launcher forever and it never actually start the download (you can tell if it's downloading or not by the download speed that should be on display at the bottom of the launcher).

Solutions (All cases are possible, so don't straight up discard them just because some of them didn't work for me. And they all assume that you have your game launcher close, so start doing that before trying this):

1) Download and run the repair tool available in this thread - http://www.swtor.com/community/showthread.php?t=419492
This one should solve any corrupt file damage by partial download or some other bug. It didn't helped me, but it's not that big of a file, so it's worth give it a shot.

2) Go to your swtor directory and open (with any txt editor) a file called launcher.setting. Change the lines
----- "PatchingMode": "{ \"swtor\": \"BR\" }" to "PatchingMode": "{ \"swtor\": \"SSN\" }"
----- "bitraider_disable": false to "bitraider_disable": true
Save the file and delete the BitRaider, Movie and Asset folders then start the launcher (if you just installed the game, it should only have the BitRaider folder). THIS is the solution that worked out for me and solve any problems that your firewall or anti-virus have with BitRaider. Pay attention to how each command looks like in the file, to make sure the syntax is correct.

3) The most obvious solution (that didn't worked for me, by the way) is re-install the game. This shouldn't fix anything the first solution won't fix, but I said I would put everything here so there you go

Hope this help everyone

Emersyn's Avatar


Emersyn
10.21.2015 , 11:11 AM | #2
Quote: Originally Posted by TyronWind View Post
3) The most obvious solution (that didn't worked for me, by the way) is re-install the game. This shouldn't fix anything the first solution won't fix, but I said I would put everything here so there you go

Hope this help everyone
This is the solution that worked for me Informative post. I usually just end up uninstall / reinstall myself (since my internet connection is pretty decent, its not that much of a burden to redownload 20GB) -

Cheers!
For 7 Days of free Subscription Time, A Free Transfer,
Free Hugs, Free kittens, and 10 extra bank slots:

>> >> Click Me! << <<
I want to play as a Jawa

ProKsnNwk's Avatar


ProKsnNwk
10.23.2015 , 02:40 AM | #3
Did you check your Windows services.
Usually just msconfig and check if BitRaider its on, if its off turn it back on.
Otherwise you can also access services by running services.msc in Search Program or Windows Run.
Same search for BitRaider and check if its on.

Nice to hear that you managed to solve your issue.
If you would like Free Goodies, 7 Days Subscription and Character Transfer
Then use my Friend Referral link: http://www.swtor.com/r/WYD7rV
Rules and Rewards Info

felicatas's Avatar


felicatas
07.18.2017 , 09:08 PM | #4
Thanks for the info Tyron. I tried everything i could find through bioware but nothing worked The fix that helped you appears to have taken care of my problems too

jediofrick's Avatar


jediofrick
05.04.2020 , 03:37 PM | #5
When I click to start the launcher it begins doing it's usual installations before taking me to SWTOR Game launcher. Today when I tried to start it, it wouldn't take me to the Game launcher it just asked if it could make changes to my device and when I answered (I answered yes) It just closes and I waited for 5 minutes. Nothing at all happened. Do you have a solution for that? I couldn't find anything. It might be called patching in the launcher but not sure. The link in there I did find something that could have helped except it was old I couldn't go to a link they mentioned. this is the link that isn't working: http://cdn-patch.swtor.com/patch/Lau...lityP1.8.0.exe

jediofrick's Avatar


jediofrick
05.06.2020 , 12:12 PM | #6
Quote: Originally Posted by jediofrick View Post
When I click to start the launcher it begins doing it's usual installations before taking me to SWTOR Game launcher. Today when I tried to start it, it wouldn't take me to the Game launcher it just asked if it could make changes to my device and when I answered (I answered yes) It just closes and I waited for 5 minutes. Nothing at all happened. Do you have a solution for that? I couldn't find anything. It might be called patching in the launcher but not sure. The link in there I did find something that could have helped except it was old I couldn't go to a link they mentioned. this is the link that isn't working: http://cdn-patch.swtor.com/patch/Lau...lityP1.8.0.exe
I fixed it by reinstalling twice. Thanks for creating this anyways.