Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Fate of the Jedi, class quest help

STAR WARS: The Old Republic > English > Classes
Fate of the Jedi, class quest help

Klowdy's Avatar

02.05.2013 , 08:33 AM | #41
I just had problems with this quest yesterday, I couldn't even fly to the oppressor. Try turning your video settings all the way down, then use the holocom. It worked for me, but you may be having a different issue than I was.

Nicolettexiv's Avatar

02.07.2013 , 01:09 AM | #42
This bugged out for me as well. I could complete the Oppressor phase, and check in with my holoterminal once I got back on my ship, but once I traveled to Tython, my quest, Fate of the Jedi, won't update. I just get arrows directing me outside of the temple, but nothing is there. (The quest dialogue simply says "Travel to Tython".. it never updates to go to the council, as if I haven't traveled yet.)

My friend and I are leveling Jedi Knights together. He's a guardian, I'm a sentinel. We did my phase first, then his. He was able to complete the Tython portion of his quest, and continue on with the class storyline. I am not.

I have tried:
- Going to another planet, and back to Tython.
- Going to Tatooine, and back to Tython.
- Going to the Fleet, and back to Tython.
- Using a Fleet Pass, and then going back to Tython.
- Reset all active phases.
- Logged out of Character.
- Quit game client.

There is no option to reset the quest. I was told to "open a ticket" and tech support does not offer in-game assistance over the phone (which is shocking, for a game with so many issues NOT to offer consistent nor reliable support.) The "fixes" the recorded message gave over the phone, for a bugged class quest, was to reset the quest. I do not have the option to reset the quest. The button is not active, and mousing over it gives the "unavailable" dialogue.

So, according to the similar issues listed above, it would seem I have to [&!^%^%!#&!^$%#!&^%$#] Re-roll. After investing into Cartel items, Legacy Character Perks, Crafting, etc. seeing as my chances of getting anything other than a "Droid" response are slim. And even then, support droid messages are never helpful, and I'll have to wait ages even for that.

I'm furious.
Don't be toxic.

Buttmidala's Avatar

10.27.2013 , 12:53 PM | #43
Travelling to The Republic Fleet solved the problem for me. Give it a try.

jdolan's Avatar

11.29.2013 , 11:02 PM | #44
im stuck too. bet everyone got off the ship but now cant talk to council just tells me to go out of the temple. Really want to move on in the story line but been here for a while. Someone please fix the glitch!!!

GefjonAsgard's Avatar

12.13.2013 , 06:32 PM | #45
Yikes - I thought it was bad enough that I can't kill Angral, even at level 33.

Didn't realise Kira would turn on me as well!!

GefjonAsgard's Avatar

12.13.2013 , 06:33 PM | #46
Quote: Originally Posted by troppersir View Post
i cant even beeat darth angral im lvl 32 sentinel have tried 10 times now and he uses the same atack on me every time 1900 damge each
Me too - even at Level 33

Littleaugie's Avatar

10.06.2014 , 02:53 PM | #47
Quote: Originally Posted by Skybyrd View Post
Just verifying previous statement. After finishing on the Oppressor, my quest was stuck. Tried several things, but traveling to Tatooine did fix it for me too.
I got bugged too.. travelling to tattooine worked for me too..

ArteTV's Avatar

10.19.2014 , 06:09 AM | #48
Experienced the same issue. Didn't get past "Travel to Tython". The "Reset" option was not available either.

Travelling to Tatooine solved it for me as well.

Nevertheless it is a shame that this bug is known for almost THREE YEARS and still NOT FIXED. Even more since similar bugs seem to appear also elsewhere in the game. As a subscriber I expect a properly working game, and especially those, who might have invested lots of money into cartel coins, have a right to do so. Not the way you should treat your customers...

Tarurelm's Avatar

05.17.2015 , 08:30 PM | #49
Just an FYI, my friend that I am running through a Knight with is experiencing this issue now. Though we are running all missions together, I did not encounter this issue. It is a shame that this bug is still in the game since launch, it would seem. C'mon Bioware, I know you're better than this. I understand this might be a hard bug to duplicate and find a solution but c'mon.
@ Satele Shan The Relm Legacy
-DPS- Vig Guard/ Veng Jug Täru/Ciare-
-Heals- Sage/Sorc- Va'shh/ Nihk-

LincolnWithHat's Avatar

11.25.2015 , 09:56 AM | #50
This is still around and travelling to other planets doesn't seem to be fixing it for me. Not exactly ideal.
Have gun? Will travel.