Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Problem with the launcher

ejderklev's Avatar


ejderklev
06.18.2019 , 07:20 AM | #1
Does anyone else have problems with the launcher, not being able to log in on the launcher? Please help

Mcgregja's Avatar


Mcgregja
06.18.2019 , 08:27 AM | #2
Same. Getting message that the login service is down. Hoping it's related to the character SH issue and not another one they need to solve.

OwenBrooks's Avatar


OwenBrooks
06.18.2019 , 08:32 AM | #3
Login works for me from Australia maybe ISP/Region issue if still occurring for more then one person

best to wait at present and see if it clears on its own if it doesnt post in the swtor technical issues forum at https://answers.ea.com/t5/Technical-...ld-republic-en

Mcgregja's Avatar


Mcgregja
06.18.2019 , 08:50 AM | #4
That's strange. I VPN'd into another region and the message doesn't display on starting the launcher. However, it does display once I enter my info and attempt to log in.

Also, I only received this message after running FitLauncher.exe. Prior to that, I was able to connect and got stopped at the character SH issue.

OwenBrooks's Avatar


OwenBrooks
06.18.2019 , 08:57 AM | #5
fixlauncher.exe hasnt been a recommended step for a long time and definitely not for streaming launcher

there is a repair utility at https://answers.ea.com/t5/Troublesho.../m-p/4805820#2 note: this will likley reinstate bitraider as the default patch method so would need to switch to SSN again if it does and you prefer non streaming.

Mcgregja's Avatar


Mcgregja
06.18.2019 , 09:03 AM | #6
Thanks, that did the trick.

OwenBrooks's Avatar


OwenBrooks
06.18.2019 , 09:04 AM | #7
Quote: Originally Posted by Mcgregja View Post
Thanks, that did the trick.
Glad to hear your good now

May The Force be With You