Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Quest Bugged: Pirrell's Ambitions

STAR WARS: The Old Republic > English > Classes
Quest Bugged: Pirrell's Ambitions

Saiphos's Avatar

12.21.2011 , 04:49 PM | #11
I had this same issue. Like Istalon said, I had to reset the mission back TWO steps to fix it. After I reset it the first time, I went to Drumond Kass, left my ship and got the option to reset it again in the hangar. Then when I went back to Balmorra I got the cutscene.

I think it might have been caused by leaving your ship on Balmorra before using the holocommunicator to progress the story. I noticed that the mission summary when I had the error said I had used the holocommunicatior, but I hadn't.

HolgB's Avatar

12.21.2011 , 10:14 PM | #12
I tried resetting on Ballomar and Drumond Kass and did not have any luck. No mater what I cannot speak to the droid. I guess i'll just have to wait a week till they get to my ticket.

Obilam's Avatar

12.22.2011 , 01:06 AM | #13
I have a problem too.

I've gotten almost three steps through the mission and am reporting back to Pirrells but when i right click on him i get the square with three dots loading icon, but nothing loads.

Going to try again this morning.

HolgB's Avatar

12.23.2011 , 08:02 AM | #14
Has anyone figured out a solution for this or get their tickets answered?????

Badco's Avatar

12.24.2011 , 10:09 PM | #15
This happened to me as well.

The cut scene did not happen for me.

I had to shuttle back to the previous planet and reset the quest, then it worked fine. (You can reset the quest once you enter your shuttle, but it was still bugged once i exited)

Achylon's Avatar

12.25.2011 , 03:29 PM | #16
Still got the problem.

Can't talk to the robot, the door won't open and so I can't even talk to Pirrell...

Friggin sucks, cause im already lvl 29 and can't do the class quest which started
on Balmorra.

HolgB's Avatar

12.28.2011 , 09:41 AM | #17
I reset and tried the quest again after the latest patch and it has not been fixed... I guess they don't want us progressing our characters.

ethanfel's Avatar

12.28.2011 , 03:29 PM | #18
A guildmates of mine got the issue too.

He reset the quest (on the planete, in the mantis or everywere) kill or let live the two douchbag when he leave his ship.

Go see pirrel, and he can't open the door, the droid say "hello" and nothing else.

ethanfel's Avatar

12.29.2011 , 11:55 AM | #19
nothing new

Ultimatewarrior's Avatar

12.29.2011 , 09:28 PM | #20
I'm stuck also, same problem, door is closed and can't see Pirrell. Level 32 now ; /